Page 1 of 1

Good and Bad

PostPosted: Jul 11th, '19, 04:35
by MikeFinch
OK we now have Mageia 7 - at last! I would like to raise the following comments/observations ==>

A) I thought I had saved a draft message a couple of days ago; where on earth do drafts "live" on this website?

B) Good : on my laptop using Mageia 6 I failed for months to connect to wifi at home and only sporadically away from home; I have now been able to connect with M7. Hoorah!

C) Bad : I use xampp (linux : lampp) for a data management project. It installs and runs perfectly on M6; the identical code and database will not work with M7. Why? Plain frustrating. Can someone please check the lampp installation using M7.

D) This one is now redundant : I was going to complain about M7 suddenly not booting (a three-line message which I was going to spell out). Just observed that M7 eventually appeared. Why the delay? Sorry I can't be more specific.

MikeFinch - PS I have just noticed "Load draft" and "Save draft"; answers my A)! :)

Re: Good and Bad

PostPosted: Jul 11th, '19, 09:28
by ITA84
A) EDIT: didn't see your PS, nevermind

B) that's nice to hear ^^

As for C and D, I'd suggest you make separate topics and add some more details so people might help you (I suppose D isn't a problem anymore, but if it does happen again don't be afraid to ask for help)

Re: Good and Bad

PostPosted: Jul 13th, '19, 03:48
by MikeFinch
Thankyou ITA84 ==>

OK will try another topic for xampp - using M6 alright at the moment though I'd like to use M7.

I am revisiting D). This morning I failed several times to boot M7 on [this] Dell Inspiron laptop. Frustrating. A three-line (possibly the same as the one I mentioned previously) appears. As follows:
"[ [some letters and numbers] Unexpected ACPI:SPCR:Access Width Defaulting to byte siz [next line] e
[ [slan] mei mei [slan] Could not read FW version
[[ditto to mei] FW version command failed -5"
Later on this additionally appeared : [[slan] brcmsmac bcma 0:1:brcms_ops_start:brcms_up() returned [slan - I think] 132.
Sometimes the splash screen appeared (boiling couldron) and then back to those 3 lines.

Now hear this : I decided to clear some dust at the top of my touchpad by using my thumbnail - the main M7 screen suddenly appeared!!!. What the h... happened??

As a relevant point - a couple of days ago I received an email from Broadcom about a new linux driver. I don't know how to install it unfortunately.
I have had Mageia messages for years stating that Broadcom is inoperative and I use the alternative. Also the above error lines appear to be referencing Broadcom.
For ages I have muttered under my breath about Mageia's inability to handle wifi properly (btw once again ethernet has worked instantly).

Does the info above give you some idea about what is going on, please? Maybe a solution will fix the (apparent Broadcom) problem(s) for good.

Re: Good and Bad

PostPosted: Jul 13th, '19, 12:22
by martinw
Your problem D may be the system is waiting for the random number generator to be initialised. This normally only occurs if you have an older CPU which doesn't have a hardware random number generator and you have replaced your hard disk with a SSD. The system wants some truly random numbers to seed its random number generator. Hitting the Enter key a few times or moving the mouse provides these. Does that consistently fix the slow boot for you?

I sympathise with your Broadcom WiFi problems. I used to have a laptop with a Broadcom WiFi adapter, and it was a lottery whether WiFi would work or not with each kernel/driver update. I had to keep switching between the proprietary and free driver, as sometimes one would work, sometimes the other (and sometimes neither :-( ). My solution was to replace the WiFi adapter with an Intel one.

Re: Good and Bad

PostPosted: Jul 14th, '19, 02:32
by MikeFinch
Thankyou martinw for your response.

Yes I replaced the original HD with a SSD. Didn't know about the random number business, so will press the enter key a few times next time I have the problem (don't use a mouse). I will let my linux meeting (SSD) friends know about this (

Would you mind expanding on "replace the WiFi adapter with an Intel one"? Do you have an opinion on the new Broadcom linux driver?

Re: Good and Bad

PostPosted: Jul 14th, '19, 10:26
by martinw
Tapping or brushing the touchpad should also work to seed the random number generator.

In my old laptop, the WiFi adaptor was on a small plugin card, which could be accessed by removing a panel on the rear cover. Some versions of that laptop came with a Broadcom card, others with an Intel card, so I knew the Intel one would work. IIRC, I bought one off eBay. Unplugged the old card, plugged in the new one, and it worked straight away.

I made sure my current laptop didn't have Broadcom WiFi, so can't comment on the latest drivers.

Re: Good and Bad

PostPosted: Jul 16th, '19, 04:26
by johnpenguin
The Atheros chips work pretty well as well and you can find them at really attractive prices.

Re: Good and Bad

PostPosted: Jul 17th, '19, 01:51
by MikeFinch
OK johnpenguin : I will consult my linux group next Friday; it is my presentation day!

GOOD : My original C) was nonsense. I have discovered how to create/change the password in phpmyadmin; the option is somewhat hidden in phpmyadmin's menu structure. So lampp works!

BAD (AGAIN) : On my original B) : I managed to connect to wifi for 4 or 5 days and then lost it again (after using the Council's free wifi Friday morning). The system is picking up zilch now : a blank screen, even after refreshing. I simply don't understand what goes wrong. Can anyone help? Ethernet works perfectly.

Re: Good and Bad

PostPosted: Jul 18th, '19, 21:52
by morgano
Regaring wifi; do you happen to have a mechanical switch, BIOS function, or keyboard button combo to switch it on/off?
Fooled me once...

BOCH emulator

PostPosted: Jul 18th, '19, 22:54
by mmm
Mag 7 would be a great choice for servers if it booted nicely in BOCHs which can be rented in the cloud at almost no cost (well 4€ per month) but almost nothing for 3 days of testing , then deleting the v-server and pay just µ €cents or whatever.

Re: Good and Bad

PostPosted: Jul 20th, '19, 10:19
by MikeFinch
Thanks folks for replies. Last Friday and since, I get absolutely nothing for wifi. No other networks - zilch.

I have no wifi switches but I will take the only back cover off (when I get round to it). This was last removed when the SSD was installed. I'm not very good at this - if I find a wifi socket I presume it is a simple matter of replacing the wifi card?

According to MCC I currently have A) "enp5so: Qualcomm Atheros|AR8152 v1.1 Fast Ethernet"; B) "wlp4s0b1: Intel Corporation|Core Processor DRAM Controller"; and C) "wifi (wlp0s29ulu4)".

A) works perfectly but B) and C) are presently a washout. I was using B) at my meetings but useless - presumably - here at home (except for 4 days recently).

I would appreciate assistance from knowledgeable people on this. I have the recent Broadcom linux info, with Makefile and C code but no README. The one person in my linux group with C knowhow wasn't there at our Friday meeting and no-one else is knowing enough on the subject. Also my home wifi actually worked for 4 or 5 days then went off again.

Is it the age of my Dell Inspiron (8 years)? My mates keep prodding me to get a recent model but I don't think I need to (do I?).

Any help will be good!

Re: Good and Bad

PostPosted: Jul 20th, '19, 10:35
by martinw
It seems odd that you apparently have two WiFi adapters, and even more odd that one of them is described as a DRAM controller. What is the output from running
Code: Select all
lspcidrake -v

in a terminal?

Re: Good and Bad

PostPosted: Jul 21st, '19, 06:16
by MikeFinch
martinw - I appreciate your interest. The attached textfile (wifiprobs) is somewhat verbose!

I hope it is informative.

Re: Good and Bad

PostPosted: Jul 21st, '19, 10:37
by martinw
Well, the device described as "Intel Corporation|Core Processor DRAM Controller" really is a DRAM controller, so I don't know why it is being offered up as wireless interface!

For your Broadcom WiFi, check that it has not been disabled by running the command
Code: Select all

If that shows your device as being blocked, that is the problem. If not, you could test whether the proprietary Broadcom driver works better. In a terminal, as root, run
Code: Select all
urpmi dkms-broadcom-wl
modprobe -r ssb brcmsmac bcma
modprobe wl

Then use MCC to set up your wireless connection again. If it's no better, remove the dkms-broadcom-wl package and any packages that were installed as dependencies, to prevent them interfering with the non-proprietary driver.

Re: Good and Bad

PostPosted: Jul 22nd, '19, 07:07
by MikeFinch
martinw > I followed your suggestions.
rfkill showed SOFT as unblocked and HARD as blocked.
I won't bore you with the rest apart from the fact that "modprobe wl" gave "modprobe: FATAL: Module wl not found in directory /lib/modules/5.1.14-desktop-1.mga7".
One of the messages - in MCC - seemed to mention the website where you can download what looked like Broadcom's new linux driver. I had done the download a few days ago, and as I said there is no README file to read and I don't know how to handle the sourcecode provided - Makefile and all that. The driver is called the "Linux[R] STA 64-bit driver". Can you shed any light on this driver?
I hope to consult our member who understands C : if he turns up next Friday (26 July). Broadcom is (I believe) famous for not handling linux well; the new driver however may be the result of that bad reputation.
We'll see what happens with any linux driver installation attempt.

Re: Good and Bad

PostPosted: Jul 22nd, '19, 11:05
by martinw
If rfkill shows that your wireless interface is hard blocked, that means it is disabled, so I wouldn't expect any driver to work. Hard blocked normally means that it has either been disabled in the BIOS or by the dedicated function key you find on most laptops (usually a combination of "Fn" + one of the normal function keys). Given that your wireless worked for several days and then stopped, it seems likely that it has got accidentally turned off.

The dkms-broadcom-wl package contains the Broadcom STA 64-bit driver. The version contained in the package is the latest version available at - - but that claims to date from 2015, so I don't know where your new version comes from.

By the way, does rfkill also list the spurious wireless interface, or just the real one?

Re: Good and Bad

PostPosted: Jul 25th, '19, 08:02
by MikeFinch
martinw >> again thanks.

rfkill produces nothing at all, root or user. Why?

Fortunately I still have my paper copy of the earlier rfkill. It is
0 wlan phy0 unblocked blocked".

I suspect that FN F2 is my wifi switch because there is an aerial logo on the F2 key. Pressing that - often - seems to do nothing.

I have just had a deeper look at the Broadcom site and, yes, the Linux driver is dated in 2015. And I found and saved a 7 and a half page README file!

Broadcom's email is dated 10 July and headed "New or Updated 'Linux [R] STA 64-bit driver' is available". You and I can only see the 2015 effort!

They suggest (near top of page 2) "lspci -n | grep 14e4"; I get "04:00.0 0280: 14e4:4727 (rev 01)". The whole procedure sounds very complicated (kernel-devel, etc). I wouldn't know how to mess about with the kernel.

I have looked at the attempted wifi connection and get Broadcom error messages:
1. "Could not install the package (dkms-broadcom-wl, dkms-broadcom-wl)!";
2. "Some packages (broadcom-wl) are required but aren't available. These packages can be found in Mageia, or in the official non-free package repository. The following component is missing: wl. The required files can also be installed from this URL: http://www.broadcom/support/802.11/linux-sta.php" [As you observed]

I have sidestepped Broadcom for years (since it never worked) so don't remember if these messages appeared in M6.

In MCC - Wireless. Select the network interface to configure:
1. Broadcom Inc. and subsidiaries BCM4313 802.11bgn Wireless Network Adapter
2. Use a Windows-driver (with ndiswrapper).
For ages there was a third "network"? I used all the time; it has disappeared (in MCC). It might have been 'wlpOs29ulu4' - just discovered it is mentioned in active (the only wireless) interfaces on the Mageia desktop toolbar 'Active interfaces' menu option. Although I have a feeling it was another network.

On the desktop I am usually asked for my root password and then the Network box appears in the top-left corner; sometimes I am not asked for the password and the Network box has been disappearing. Sometimes rebooting helps me get on line but even that doesn't seem to work.

Where do we go from here please? Is it possible that the FN F2 key is not working? How are keyboards fixed?!

As ever, ethernet works perfectly.

Re: Good and Bad

PostPosted: Jul 26th, '19, 12:11
by martinw
I begin to wonder if there is an intermittent bad connection in your laptop, so sometimes the Broadcom wireless is working, sometimes it isn't.

To install dkms-broadcom-wl, you need to have the nonfree media enabled. What does
Code: Select all
urpmq --list-media active


Re: Good and Bad

PostPosted: Jul 27th, '19, 02:47
by MikeFinch
martinw > AFAIK Broadcom has never worked!

Attached the outcome of your suggestion. I have not changed the sources recently.

Re: Good and Bad

PostPosted: Jul 31st, '19, 09:21
by MikeFinch
NOTE YE ALL! I have just installed Manjaro Linux 17.1 (64bit).

At first I thought wifi wouldn't work : BUT NOW HAVE IT WORKING!!!!

So I suppose software has become entangled somehow with my Mageia 7. The question is, how do I unentangle it - i.e. cleanup the files?

I could always change permanently to Manjaro but I have used Mageia and its forebears for years and would like to remain "faithful"!

When on Friday (2 August) I attend my linux group meeting I would like to think I will also link to the Council's free wifi satisfactorily. We'll see.

Re: Good and Bad

PostPosted: Aug 9th, '19, 00:13
by MikeFinch
Installed Mageia 7.1 and wifi now working (at home).
My problem now is that Manjaro won't boot (kernel panic).
Any help welcome!

Re: Good and Bad

PostPosted: Aug 9th, '19, 08:31
by isadora
It is advised, to have new topics opened for different issues.

Re: Good and Bad

PostPosted: Aug 10th, '19, 03:28
by MikeFinch
Sorry! - will open another topic.

It took me probably more than an hour to connect to the local Council's free wifi Friday morning but I eventually managed it. Can't recollect exactly how I did it. Back home, connected to wifi easily!! Hooray!

The following is relevant to this topic I think - I am continually told (still) that (in 7.1) the Broadcom network is unavailable; this is annoying.

Can I remove (and how please) the Broadcom bit for good and all? Broadcom has never worked and their so-called 'new' linux driver is a 2015 effort.