Setup of Realtek RTL8852 Wifi Adapter on Lenovo Legion 5

Here you'll find a place for solutions and hints.

Please use one of the support subforums below for questions or if you have any issues and need support.

Setup of Realtek RTL8852 Wifi Adapter on Lenovo Legion 5

Postby duncangareth » Aug 28th, '21, 00:06

My trusty Lenovo Thinkpad W530 died, and due to a shortage of funds, I replaced it with a Lenovo Legion 5 15ach6 gaming laptop. This machine uses a Ryzen 7 cpu and an integrated NVME SSD and Realtek network interfaces. When I ordered the machine, I had no idea that I would have trouble setting up the wifi interface after installing Mageia 8.

The controller is listed as "Network controller: Realtek Semiconductor Co., Ltd. Device 8852" in the "lspci" listing.

When I tried to configure the wifi interface using MCC, the interface is listed, but, when selected, it returns an error message stating that the interface can't be found. This seems rather absurd, since the device is listed correctly by the utility.

I solved the problem in the following way:

In a root terminal session, run the following, after installing git and the relevant kernel development package:
Code: Select all
git clone https://github.com/lwfinger/rtw89.git -b v5
cd rtw89
make
make install
modprobe -r rtw89_pci
modprobe -r rtw89core
modprobe rtw89pci

This will remove the malfunctioning kernel module and replace it with the correct one.
duncangareth
 
Posts: 64
Joined: Oct 24th, '13, 21:05

Re: Setup of Realtek RTL8852 Wifi Adapter on Lenovo Legion 5

Postby doktor5000 » Aug 28th, '21, 00:19

Thanks for sharing :)
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16797
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany


Return to The magician suggests...

Who is online

Users browsing this forum: No registered users and 1 guest