[SOLVED] Spotify App for Mageia6

This forum is for general chat between members about Mageia.

Technical questions are supposed to be posted in support forums. Not here !

[SOLVED] Spotify App for Mageia6

Postby marcpare » Jun 25th, '18, 01:03

For those looking to install the Spotify app on their Mageia6 box, here are directions on how to do it. I based these directions from a previous discussion on the same topic here: https://forums.mageia.org/en/viewtopic.php?t=11003, but, have added some additional notes just for the sake of clarity.

1. install flatpak from the Mageia6 repositories (through MCC is fine)
*** there is no need to reboot your computer
2. Install the "flathub.org" flatpak repo and download the spotify client. Type (copy/paste) the following in console (do not do this at root level)
Code: Select all
$ flatpak install --from https://flathub.org/repo/appstream/com.spotify.Client.flatpakref

3. agree to messages from this part of the installation ... it will most likely ask you to
**** install runtimes from "flathub.org"
*** install org.freeedesktop.Platform/x86_64 ....[/list]
4. when installation is complete, log out and back into your account
5. the Spotify app will appear in your "Start-Sound/Video->More" menu
6. If you wish, you can drag the app to your desktop and "link" it

Note that on one of my systems, when I dragged the Spotify app to my desktop to add it as a "link-shortcut", only the name "Spotify" appeared but with no Spotify icon (green coloured icon).
If this happens, you could

1. download an icon from https://developer.spotify.com/branding-guidelines/ -- save it somewhere you can find it again
2. create a new link on your desktop and use as icon image the Spotify image you just downloaded
3. note that for the actual link to the program, you should put down should be:
Code: Select all
/usr/bin/flatpak run --branch=stable --arch=x86_64 --command=spotify --file-forwarding com.spotify.Client @@u %U @@

*** this is the same link that is used by the Spotify app menu item in your Mageia Start menu

That's it! All that is left to do is to double-click on your Spotify icon and log into your Spotify account if you have one.

Cheers,

Marc
marcpare
 
Posts: 16
Joined: Jun 10th, '11, 03:20
Location: Waterloo Ontario, Canada

Re: [SOLVED] Spotify App for Mageia6

Postby morgano » Jun 25th, '18, 01:25

Thank you Marc.
I think your post belongs in the HOWTO thread viewtopic.php?t=11003 covering various methods to install Spotify.
Maybe an admin can move it?
Mandriva since 2006, then Mageia since 2011 at home & work. Thinkpad T42p T43 T60 T61 T400. Aspire 7. Workstation using LVM, LUKS, VirtualBox, BOINC, CAD
morgano
 
Posts: 590
Joined: Jun 15th, '11, 17:51
Location: Kivik, Sweden

Re: [SOLVED] Spotify App for Mageia6

Postby morgano » Sep 23rd, '19, 17:58

Now i see one thing: at step 2 we should use the flag " --user " so it is installed for the user only. Like in the mentonned thread.
Mandriva since 2006, then Mageia since 2011 at home & work. Thinkpad T42p T43 T60 T61 T400. Aspire 7. Workstation using LVM, LUKS, VirtualBox, BOINC, CAD
morgano
 
Posts: 590
Joined: Jun 15th, '11, 17:51
Location: Kivik, Sweden

Re: [SOLVED] Spotify App for Mageia6

Postby doktor5000 » Sep 23rd, '19, 23:15

And if you have multiple users, you suggest to install it for each user ?
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 15240
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: [SOLVED] Spotify App for Mageia6

Postby morgano » Sep 27th, '19, 17:12

That is a point.

BTW, currently it refuse to install one component needed for Soptify:

Warning: org.freedesktop.Platform.openh264 needs a later flatpak version

=> https://bugs.mageia.org/show_bug.cgi?id=25463

- which renders Spotify launching but unable to play.
Mandriva since 2006, then Mageia since 2011 at home & work. Thinkpad T42p T43 T60 T61 T400. Aspire 7. Workstation using LVM, LUKS, VirtualBox, BOINC, CAD
morgano
 
Posts: 590
Joined: Jun 15th, '11, 17:51
Location: Kivik, Sweden

Re: [SOLVED] Spotify App for Mageia6

Postby morgano » Oct 24th, '19, 20:09

Patch for leamas-spotify script to make it work on Mageia 7 and other distors where default python version is 3 is posted at
https://github.com/leamas/spotify-make/issues/58

Meaning, as I read it:

Follow the chapter "Installation" https://github.com/leamas/spotify-make#Installation
And open the file spotify.make/Makefile.in and in the line
Code: Select all
 lib_to_data  := $(shell python -c 'import os.path;                          \
edit "python" to "python2".
Then continue with chapter "Usage" etc

After the install i get when trying to launch:
Code: Select all
$ ~/bin/my-spotify
/home/morgan/.local/lib/spotify-client/spotify: error while loading shared libraries: libQtDBus.so.4: cannot open shared object file: No such file or directory

So I installed lib64qtdbus4.
But next try to start spotify, it say:
Code: Select all
/home/morgan/.local/lib/spotify-client/spotify: /lib64/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /home/morgan/.local/lib/spotify-client/spotify)
/home/morgan/.local/lib/spotify-client/spotify: /lib64/libssl.so.1.0.0: version `OPENSSL_1.0.0' not found (required by /home/morgan/.local/lib/spotify-client/spotify)
/home/morgan/.local/lib/spotify-client/spotify: /home/morgan/.local/lib/spotify-client/libgcrypt.so.11: version `GCRYPT_1.2' not found (required by /home/morgan/.local/lib/spotify-client/libcef.so)

Checking:
libcrypto.so.1.0.0 is in installed package lib64compat-openssl10_1.0.0
libssl.so.1.0.0 is in installed package lib64compat-openssl10_1.0.0lib
That /home/morgan/.local/lib/spotify-client/libgcrypt.so.11 is a link pointing to /lib64/libgcrypt.so.20 which exist because installed lib64gcrypt20

So if i understand correctly, spotify "only" think there are wrong versions, and refuse to try...?
Mandriva since 2006, then Mageia since 2011 at home & work. Thinkpad T42p T43 T60 T61 T400. Aspire 7. Workstation using LVM, LUKS, VirtualBox, BOINC, CAD
morgano
 
Posts: 590
Joined: Jun 15th, '11, 17:51
Location: Kivik, Sweden

Re: [SOLVED] Spotify App for Mageia6

Postby Hurr » Nov 22nd, '19, 22:27

I have the same problem, but I think the installed openssl version is 1.1.0:

Code: Select all
$ rpm -q openssl
openssl-1.1.0j-1.mga7


Anyone know any solution?
Hurr
 
Posts: 3
Joined: Nov 22nd, '19, 22:23

Re: [SOLVED] Spotify App for Mageia6

Postby doktor5000 » Nov 26th, '19, 18:23

Why not simply install spotify as flatpak ?
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 15240
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: [SOLVED] Spotify App for Mageia6

Postby Hurr » Nov 26th, '19, 18:38

Because the spotify flatpak package doesn't work in MGA7. It's necessary an update of the MGA7 flatpak package.

There's already a bug reported:
https://bugs.mageia.org/show_bug.cgi?id=25463
Hurr
 
Posts: 3
Joined: Nov 22nd, '19, 22:23

Re: [SOLVED] Spotify App for Mageia6

Postby doktor5000 » Nov 27th, '19, 18:47

But that's not due to the openh264 message, and that only appears after several flatpak updates. On a fresh mga7 install, spotify installs just fine, and doesn't even need openh264:

Code: Select all
[doktor5000@Mageia7VM ~]$ flatpak install flathub com.spotify.Client
Looking for matches…
Required runtime for com.spotify.Client/i386/stable (runtime/org.freedesktop.Platform/i386/18.08) found in remote flathub
Do you want to install it? [Y/n]:

com.spotify.Client permissions:
    ipc      network      pulseaudio     x11     dri     file access [1]     dbus access [2]     bus ownership [3]     tags [4]

    [1] xdg-music:ro, xdg-pictures:ro
    [2] org.freedesktop.Notifications, org.gnome.SessionManager, org.gnome.SettingsDaemon
    [3] org.mpris.MediaPlayer2.spotify
    [4] proprietary


        ID                                               Arch            Branch            Remote            Download
 1. [✓] org.freedesktop.Platform                         i386            18.08             flathub           292.8 MB / 306.7 MB
 2. [✓] org.freedesktop.Platform.Locale                  i386            18.08             flathub            17.3 kB / 316.0 MB
 3. [✓] org.freedesktop.Platform.html5-codecs            i386            18.08             flathub             3.3 MB / 3.4 MB
 4. [✓] com.spotify.Client                               i386            stable            flathub           109.0 MB / 109.0 MB

Installation complete.
[doktor5000@Mageia7VM ~]$


The following are the errors when running spotify, and those are not an issue with flatpak itself:
Code: Select all
[doktor5000@Mageia7VM ~]$ flatpak run com.spotify.Client
/app/extra/bin/spotify: /usr/lib/i386-linux-gnu/libcurl.so.4: no version information available (required by /app/extra/bin/spotify)
Gtk-Message: 11:40:18.659: Failed to load module "canberra-gtk-module"
/app/extra/share/spotify/spotify: /usr/lib/i386-linux-gnu/libcurl.so.4: no version information available (required by /app/extra/share/spotify/spotify)
[1127/114018.719115:ERROR:nss_util.cc(747)] After loading Root Certs, loaded==false: NSS error code: -8023
[1127/114019.398703:ERROR:cert_verify_proc_nss.cc(902)] CERT_PKIXVerifyCert for www.googletagmanager.com failed err=-8179
[1127/114019.574005:ERROR:cert_verify_proc_nss.cc(902)] CERT_PKIXVerifyCert for spclient.wg.spotify.com failed err=-8179
[doktor5000@Mageia6VM ~]$ [1127/114024.056057:ERROR:cert_verify_proc_nss.cc(902)] CERT_PKIXVerifyCert for redirector.gvt1.com failed err=-8179
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 15240
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: [SOLVED] Spotify App for Mageia6

Postby Hurr » Nov 27th, '19, 20:11

This is in my system:

1. Install

Code: Select all
$ flatpak install flathub com.spotify.Client
Looking for matches…
Required runtime for com.spotify.Client/x86_64/stable (runtime/org.freedesktop.Platform/x86_64/19.08) found in remote flathub
Do you want to install it? [Y/n]:

com.spotify.Client permissions:
    ipc              network                pulseaudio             x11
    dri              file access [1]        dbus access [2]        bus ownership [3]
    tags [4]

    [1] xdg-music:ro, xdg-pictures:ro
    [2] org.freedesktop.Notifications, org.gnome.SessionManager, org.gnome.SettingsDaemon

        ID                                          Arch    Branch  Remote   Download
 1. [✓] org.freedesktop.Platform                    x86_64  19.08   flathub    223,7 MB / 237,7 MB
 2. [✓] org.freedesktop.Platform.GL.default         x86_64  19.08   flathub     90,8 MB / 90,8 MB
 3. [✓] org.freedesktop.Platform.GL.nvidia-340-107  x86_64  1.4     flathub     39,2 MB / 39,2 MB
 4. [✓] org.freedesktop.Platform.Locale             x86_64  19.08   flathub      5,1 MB / 318,9 MB
 5. [✗] org.freedesktop.Platform.openh264           x86_64  19.08   flathub  < 593,4 kB
 6. [✓] com.spotify.Client                          x86_64  stable  flathub    126,4 MB / 126,4 MB

Warning: org.freedesktop.Platform.openh264 needs a later flatpak version
Installation complete.


2. Run

Code: Select all
$ flatpak run com.spotify.Client
/app/extra/bin/spotify: /app/lib/libcurl-gnutls.so.4: no version information available (required by /app/extra/bin/spotify)
$ Gtk-Message: 19:08:01.733: Failed to load module "canberra-gtk-module"
/app/extra/share/spotify/spotify: /app/lib/libcurl-gnutls.so.4: no version information available (required by /app/extra/share/spotify/spotify)
/proc/self/exe: /app/lib/libcurl-gnutls.so.4: no version information available (required by /proc/self/exe)
Hurr
 
Posts: 3
Joined: Nov 22nd, '19, 22:23


Return to General discussions about Mageia

Who is online

Users browsing this forum: No registered users and 1 guest

cron