Sound broken in Mageia 8 (WORKAROUND)

Sound broken in Mageia 8 (WORKAROUND)

Postby mla » Mar 8th, '21, 20:26

Have just got around to installing Mageia 8. All is well, but... no sound. A quick trip to systems settings shows a problem. Under Audio the Devices tab it shows "Built-in Audio Analog Stereo", which is correct. But under the Advanced tab, where I would expect (as on Mageia 7) "Analog Stereo Duplex" to be selected, I see "Digital Stereo (HDMI) Output + Analog Stereo Input" and there is no duplex entry on the pull-down menu. In fact, the menu is pretty short. Om Mag8. the options I get are:

Analog Stereo Input
Digital Stereo (HDMI) Output
Digital Stereo (HDMI) Output + Analog Stereo Input
Off

On Mag7 (same machine!) the same menu is

Analog Stereo Input
Analog Stereo Duplex
Digital Stereo (HDMI) Output
Digital Stereo (HDMI 2) Output + Analog Stereo Input
Digital Surround 5.1 (HDMI 2) Output + Analog Stereo Input
Digital Surround 7.1 (HDMI 2) Output + Analog Stereo Input
Digital Stereo (HDMI 3) Output + Analog Stereo Input
Digital Surround 5.1 (HDMI 3) Output + Analog Stereo Input
Digital Surround 7.1 (HDMI 3) Output + Analog Stereo Input
Digital Stereo (HDMI 4) Output + Analog Stereo Input
Digital Surround 5.1 (HDMI 4) Output + Analog Stereo Input
Digital Surround 7.1 (HDMI 4) Output + Analog Stereo Input
Digital Stereo (HDMI 5) Output + Analog Stereo Input
Digital Surround 5.1 (HDMI 5) Output + Analog Stereo Input
Digital Surround 7.1 (HDMI 5) Output + Analog Stereo Input
Off

Why the difference and what should I do to get sound working on my speakers?
Last edited by mla on Mar 9th, '21, 13:45, edited 1 time in total.
mla
 
Posts: 292
Joined: Sep 16th, '11, 16:10

Re: Sound broken in Mageia 8

Postby doktor5000 » Mar 8th, '21, 21:07

Dumb question - this is a different system then the one from the other thread with disappearing sound? viewtopic.php?f=26&t=13975

Could you please add the output as regular user from
Code: Select all
LC_ALL=C pacmd ls
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16739
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Sound broken in Mageia 8

Postby mla » Mar 8th, '21, 21:53

Why dumb? Same system. I'll reboot to Mag8 for that pacmd command...
mla
 
Posts: 292
Joined: Sep 16th, '11, 16:10

Re: Sound broken in Mageia 8

Postby mla » Mar 8th, '21, 22:05

Here you are, boss! :-)

Code: Select all
$ LC_ALL=C pacmd ls
Memory blocks currently allocated: 1, size: 63.9 KiB.
Memory blocks allocated during the whole lifetime: 1275, size: 8.8 MiB.
Memory blocks imported from other processes: 0, size: 0 B.
Memory blocks exported to other processes: 0, size: 0 B.
Total sample cache size: 0 B.
Default sample spec: s16le 2ch 44100Hz
Default channel map: front-left,front-right
Default sink name: alsa_output.pci-0000_00_1f.3.hdmi-stereo
Default source name: alsa_output.pci-0000_00_1f.3.hdmi-stereo.monitor
Memory blocks of type POOL: 1 allocated/611 accumulated.
Memory blocks of type POOL_EXTERNAL: 0 allocated/0 accumulated.
Memory blocks of type APPENDED: 0 allocated/0 accumulated.
Memory blocks of type USER: 0 allocated/0 accumulated.
Memory blocks of type FIXED: 0 allocated/172 accumulated.
Memory blocks of type IMPORTED: 0 allocated/492 accumulated.
25 module(s) loaded.
    index: 0
        name: <module-device-restore>
        argument: <>
        used: -1
        load once: yes
        properties:
                module.author = "Lennart Poettering"
                module.description = "Automatically restore the volume/mute state of devices"
                module.version = "14.2.0-2.mga8"
    index: 1
        name: <module-stream-restore>
        argument: <>
        used: -1
        load once: yes
        properties:
                module.author = "Lennart Poettering"
                module.description = "Automatically restore the volume/mute/device state of streams"
                module.version = "14.2.0-2.mga8"
    index: 2
        name: <module-card-restore>
        argument: <>
        used: -1
        load once: yes
        properties:
                module.author = "Lennart Poettering"
                module.description = "Automatically restore profile of cards"
                module.version = "14.2.0-2.mga8"
    index: 3
        name: <module-augment-properties>
        argument: <>
        used: -1
        load once: yes
        properties:
                module.author = "Lennart Poettering"
                module.description = "Augment the property sets of streams with additional static information"
                module.version = "14.2.0-2.mga8"
    index: 4
        name: <module-switch-on-port-available>
        argument: <>
        used: -1
        load once: yes
        properties:
                module.author = "David Henningsson"
                module.description = "Switches ports and profiles when devices are plugged/unplugged"
                module.version = "14.2.0-2.mga8"
    index: 5
        name: <module-udev-detect>
        argument: <>
        used: -1
        load once: yes
        properties:
                module.author = "Lennart Poettering"
                module.description = "Detect available audio hardware and load matching drivers"
                module.version = "14.2.0-2.mga8"
    index: 6
        name: <module-alsa-card>
        argument: <device_id="0" name="pci-0000_00_1f.3" card_name="alsa_card.pci-0000_00_1f.3" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1">
        used: 0
        load once: no
        properties:
                module.author = "Lennart Poettering"
                module.description = "ALSA Card"
                module.version = "14.2.0-2.mga8"
    index: 7
        name: <module-bluetooth-policy>
        argument: <>
        used: -1
        load once: yes
        properties:
                module.author = "Frédéric Dalleau, Pali Rohár"
                module.description = "Policy module to make using bluetooth devices out-of-the-box easier"
                module.version = "14.2.0-2.mga8"
    index: 8
        name: <module-bluetooth-discover>
        argument: <>
        used: -1
        load once: yes
        properties:
                module.author = "João Paulo Rechi Vita"
                module.description = "Detect available Bluetooth daemon and load the corresponding discovery module"
                module.version = "14.2.0-2.mga8"
    index: 9
        name: <module-bluez5-discover>
        argument: <>
        used: -1
        load once: yes
        properties:
                module.author = "João Paulo Rechi Vita"
                module.description = "Detect available BlueZ 5 Bluetooth audio devices and load BlueZ 5 Bluetooth audio drivers"
                module.version = "14.2.0-2.mga8"
    index: 10
        name: <module-esound-protocol-unix>
        argument: <>
        used: -1
        load once: no
        properties:
                module.author = "Lennart Poettering"
                module.description = "ESOUND protocol (UNIX sockets)"
                module.version = "14.2.0-2.mga8"
    index: 11
        name: <module-native-protocol-unix>
        argument: <>
        used: -1
        load once: no
        properties:
                module.author = "Lennart Poettering"
                module.description = "Native protocol (UNIX sockets)"
                module.version = "14.2.0-2.mga8"
    index: 12
        name: <module-gsettings>
        argument: <>
        used: -1
        load once: yes
        properties:
                module.author = "Sylvain Baubeau"
                module.description = "GSettings Adapter"
                module.version = "14.2.0-2.mga8"
    index: 13
        name: <module-default-device-restore>
        argument: <>
        used: -1
        load once: yes
        properties:
                module.author = "Lennart Poettering"
                module.description = "Automatically restore the default sink and source"
                module.version = "14.2.0-2.mga8"
    index: 14
        name: <module-always-sink>
        argument: <>
        used: -1
        load once: yes
        properties:
                module.author = "Colin Guthrie"
                module.description = "Always keeps at least one sink loaded even if it's a null one"
                module.version = "14.2.0-2.mga8"
    index: 15
        name: <module-intended-roles>
        argument: <>
        used: -1
        load once: yes
        properties:
                module.author = "Lennart Poettering"
                module.description = "Automatically set device of streams based on intended roles of devices"
                module.version = "14.2.0-2.mga8"
    index: 16
        name: <module-suspend-on-idle>
        argument: <>
        used: -1
        load once: yes
        properties:
                module.author = "Lennart Poettering"
                module.description = "When a sink/source is idle for too long, suspend it"
                module.version = "14.2.0-2.mga8"
    index: 17
        name: <module-systemd-login>
        argument: <>
        used: -1
        load once: yes
        properties:
                module.author = "Lennart Poettering"
                module.description = "Create a client for each login session of this user"
                module.version = "14.2.0-2.mga8"
    index: 18
        name: <module-position-event-sounds>
        argument: <>
        used: -1
        load once: yes
        properties:
                module.author = "Lennart Poettering"
                module.description = "Position event sounds between L and R depending on the position on screen of the widget triggering them."
                module.version = "14.2.0-2.mga8"
    index: 19
        name: <module-role-cork>
        argument: <>
        used: -1
        load once: yes
        properties:
                module.author = "Lennart Poettering"
                module.description = "Mute & cork streams with certain roles while others exist"
                module.version = "14.2.0-2.mga8"
    index: 20
        name: <module-filter-heuristics>
        argument: <>
        used: -1
        load once: yes
        properties:
                module.author = "Colin Guthrie"
                module.description = "Detect when various filters are desirable"
                module.version = "14.2.0-2.mga8"
    index: 21
        name: <module-filter-apply>
        argument: <>
        used: -1
        load once: yes
        properties:
                module.author = "Colin Guthrie"
                module.description = "Load filter sinks automatically when needed"
                module.version = "14.2.0-2.mga8"
    index: 22
        name: <module-x11-publish>
        argument: <display=:0 xauthority=/home/mla/.Xauthority>
        used: -1
        load once: no
        properties:
                module.author = "Lennart Poettering"
                module.description = "X11 credential publisher"
                module.version = "14.2.0-2.mga8"
    index: 23
        name: <module-x11-xsmp>
        argument: <display=:0 xauthority=/home/mla/.Xauthority session_manager=local/Athlon:@/tmp/.ICE-unix/2110,unix/Athlon:/tmp/.ICE-unix/2110>
        used: -1
        load once: no
        properties:
                module.author = "Lennart Poettering"
                module.description = "X11 session management"
                module.version = "14.2.0-2.mga8"
    index: 24
        name: <module-cli-protocol-unix>
        argument: <>
        used: -1
        load once: no
        properties:
                module.author = "Lennart Poettering"
                module.description = "Command line interface protocol (UNIX sockets)"
                module.version = "14.2.0-2.mga8"
1 sink(s) available.
  * index: 0
        name: <alsa_output.pci-0000_00_1f.3.hdmi-stereo>
        driver: <module-alsa-card.c>
        flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
        state: SUSPENDED
        suspend cause: IDLE
        priority: 9030
        volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
                balance 0.00
        base volume: 65536 / 100% / 0.00 dB
        volume steps: 65537
        muted: no
        current latency: 0.00 ms
        max request: 0 KiB
        max rewind: 0 KiB
        monitor source: 0
        sample spec: s16le 2ch 48000Hz
        channel map: front-left,front-right
                     Stereo
        used by: 0
        linked by: 0
        configured latency: 0.00 ms; range is 0.50 .. 1837.50 ms
        card: 0 <alsa_card.pci-0000_00_1f.3>
        module: 6
        properties:
                alsa.resolution_bits = "16"
                device.api = "alsa"
                device.class = "sound"
                alsa.class = "generic"
                alsa.subclass = "generic-mix"
                alsa.name = "HDMI 0"
                alsa.id = "HDMI 0"
                alsa.subdevice = "0"
                alsa.subdevice_name = "subdevice #0"
                alsa.device = "3"
                alsa.card = "0"
                alsa.card_name = "HDA Intel PCH"
                alsa.long_card_name = "HDA Intel PCH at 0x6023110000 irq 178"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:00:1f.3"
                sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
                device.bus = "pci"
                device.vendor.id = "8086"
                device.vendor.name = "Intel Corporation"
                device.product.id = "02c8"
                device.form_factor = "internal"
                device.string = "hdmi:0"
                device.buffering.buffer_size = "352800"
                device.buffering.fragment_size = "176400"
                device.access_mode = "mmap+timer"
                device.profile.name = "hdmi-stereo"
                device.profile.description = "Digital Stereo (HDMI)"
                device.description = "Built-in Audio Digital Stereo (HDMI)"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        ports:
                hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: yes)
                        properties:
                                device.icon_name = "video-display"
                                device.product.name = "LG IPS FULLHD"
        active port: <hdmi-output-0>
1 source(s) available.
  * index: 0
        name: <alsa_output.pci-0000_00_1f.3.hdmi-stereo.monitor>
        driver: <module-alsa-card.c>
        flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
        state: SUSPENDED
        suspend cause: IDLE
        priority: 1030
        volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
                balance 0.00
        base volume: 65536 / 100% / 0.00 dB
        volume steps: 65537
        muted: no
        current latency: 0.00 ms
        max rewind: 0 KiB
        sample spec: s16le 2ch 48000Hz
        channel map: front-left,front-right
                     Stereo
        used by: 0
        linked by: 0
        configured latency: 0.00 ms; range is 0.50 .. 1837.50 ms
        monitor_of: 0
        card: 0 <alsa_card.pci-0000_00_1f.3>
        module: 6
        properties:
                device.description = "Monitor of Built-in Audio Digital Stereo (HDMI)"
                device.class = "monitor"
                alsa.card = "0"
                alsa.card_name = "HDA Intel PCH"
                alsa.long_card_name = "HDA Intel PCH at 0x6023110000 irq 178"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:00:1f.3"
                sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
                device.bus = "pci"
                device.vendor.id = "8086"
                device.vendor.name = "Intel Corporation"
                device.product.id = "02c8"
                device.form_factor = "internal"
                device.string = "0"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
4 client(s) logged in.
    index: 0
        driver: <module-systemd-login.c>
        owner module: 17
        properties:
                application.name = "Login Session c4"
                systemd-login.session = "c4"
    index: 5
        driver: <module-x11-xsmp.c>
        owner module: 23
        properties:
                application.name = "XSMP Session on KDE as 10b0e2686c000161523347400000021100011"
                xsmp.vendor = "KDE"
                xsmp.client.id = "10b0e2686c000161523347400000021100011"
    index: 9
        driver: <protocol-native.c>
        owner module: 11
        properties:
                application.name = "QPulse"
                native-protocol.peer = "UNIX socket client"
                native-protocol.version = "34"
                application.process.id = "2120"
                application.process.user = "mla"
                application.process.host = "Athlon"
                application.process.binary = "plasmashell"
                application.language = "en_GB.UTF-8"
                window.x11.display = ":0"
                application.process.machine_id = "02833d7a83b04738aca4180d769f130e"
                application.process.session_id = "c4"
    index: 10
        driver: <cli.c>
        owner module: 24
        properties:
                application.name = "UNIX socket client"
1 card(s) available.
    index: 0
        name: <alsa_card.pci-0000_00_1f.3>
        driver: <module-alsa-card.c>
        owner module: 6
        properties:
                alsa.card = "0"
                alsa.card_name = "HDA Intel PCH"
                alsa.long_card_name = "HDA Intel PCH at 0x6023110000 irq 178"
                alsa.driver_name = "snd_hda_intel"
                device.bus_path = "pci-0000:00:1f.3"
                sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
                device.bus = "pci"
                device.vendor.id = "8086"
                device.vendor.name = "Intel Corporation"
                device.product.id = "02c8"
                device.form_factor = "internal"
                device.string = "0"
                device.description = "Built-in Audio"
                module-udev-detect.discovered = "1"
                device.icon_name = "audio-card-pci"
        profiles:
                input:analog-stereo: Analog Stereo Input (priority 65, available: unknown)
                output:analog-stereo: Analog Stereo Output (priority 6500, available: no)
                output:analog-stereo+input:analog-stereo: Analog Stereo Duplex (priority 6565, available: no)
                output:hdmi-stereo: Digital Stereo (HDMI) Output (priority 5900, available: unknown)
                output:hdmi-stereo+input:analog-stereo: Digital Stereo (HDMI) Output + Analog Stereo Input (priority 5965, available: unknown)
                output:hdmi-stereo-extra1: Digital Stereo (HDMI 2) Output (priority 5700, available: no)
                output:hdmi-stereo-extra1+input:analog-stereo: Digital Stereo (HDMI 2) Output + Analog Stereo Input (priority 5765, available: no)
                output:hdmi-surround-extra1: Digital Surround 5.1 (HDMI 2) Output (priority 600, available: no)
                output:hdmi-surround-extra1+input:analog-stereo: Digital Surround 5.1 (HDMI 2) Output + Analog Stereo Input (priority 665, available: no)
                output:hdmi-surround71-extra1: Digital Surround 7.1 (HDMI 2) Output (priority 600, available: no)
                output:hdmi-surround71-extra1+input:analog-stereo: Digital Surround 7.1 (HDMI 2) Output + Analog Stereo Input (priority 665, available: no)
                output:hdmi-stereo-extra2: Digital Stereo (HDMI 3) Output (priority 5700, available: no)
                output:hdmi-stereo-extra2+input:analog-stereo: Digital Stereo (HDMI 3) Output + Analog Stereo Input (priority 5765, available: no)
                output:hdmi-surround-extra2: Digital Surround 5.1 (HDMI 3) Output (priority 600, available: no)
                output:hdmi-surround-extra2+input:analog-stereo: Digital Surround 5.1 (HDMI 3) Output + Analog Stereo Input (priority 665, available: no)
                output:hdmi-surround71-extra2: Digital Surround 7.1 (HDMI 3) Output (priority 600, available: no)
                output:hdmi-surround71-extra2+input:analog-stereo: Digital Surround 7.1 (HDMI 3) Output + Analog Stereo Input (priority 665, available: no)
                output:hdmi-stereo-extra3: Digital Stereo (HDMI 4) Output (priority 5700, available: no)
                output:hdmi-stereo-extra3+input:analog-stereo: Digital Stereo (HDMI 4) Output + Analog Stereo Input (priority 5765, available: no)
                output:hdmi-surround-extra3: Digital Surround 5.1 (HDMI 4) Output (priority 600, available: no)
                output:hdmi-surround-extra3+input:analog-stereo: Digital Surround 5.1 (HDMI 4) Output + Analog Stereo Input (priority 665, available: no)
                output:hdmi-surround71-extra3: Digital Surround 7.1 (HDMI 4) Output (priority 600, available: no)
                output:hdmi-surround71-extra3+input:analog-stereo: Digital Surround 7.1 (HDMI 4) Output + Analog Stereo Input (priority 665, available: no)
                output:hdmi-stereo-extra4: Digital Stereo (HDMI 5) Output (priority 5700, available: no)
                output:hdmi-stereo-extra4+input:analog-stereo: Digital Stereo (HDMI 5) Output + Analog Stereo Input (priority 5765, available: no)
                output:hdmi-surround-extra4: Digital Surround 5.1 (HDMI 5) Output (priority 600, available: no)
                output:hdmi-surround-extra4+input:analog-stereo: Digital Surround 5.1 (HDMI 5) Output + Analog Stereo Input (priority 665, available: no)
                output:hdmi-surround71-extra4: Digital Surround 7.1 (HDMI 5) Output (priority 600, available: no)
                output:hdmi-surround71-extra4+input:analog-stereo: Digital Surround 7.1 (HDMI 5) Output + Analog Stereo Input (priority 665, available: no)
                off: Off (priority 0, available: unknown)
        active profile: <output:hdmi-stereo>
        sinks:
                alsa_output.pci-0000_00_1f.3.hdmi-stereo/#0: Built-in Audio Digital Stereo (HDMI)
        sources:
                alsa_output.pci-0000_00_1f.3.hdmi-stereo.monitor/#0: Monitor of Built-in Audio Digital Stereo (HDMI)
        ports:
                analog-input-internal-mic: Internal Microphone (priority 8900, latency offset 0 usec, available: unknown)
                        properties:
                                device.icon_name = "audio-input-microphone"
                analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "audio-headphones"
                hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: yes)
                        properties:
                                device.icon_name = "video-display"
                                device.product.name = "LG IPS FULLHD"
                hdmi-output-1: HDMI / DisplayPort 2 (priority 5800, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
                hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
                hdmi-output-3: HDMI / DisplayPort 4 (priority 5600, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
                hdmi-output-4: HDMI / DisplayPort 5 (priority 5500, latency offset 0 usec, available: no)
                        properties:
                                device.icon_name = "video-display"
0 sink input(s) available.
0 source output(s) available.
0 cache entrie(s) available.
$
Last edited by doktor5000 on Mar 8th, '21, 22:16, edited 1 time in total.
Reason: added code tags
mla
 
Posts: 292
Joined: Sep 16th, '11, 16:10

Re: Sound broken in Mageia 8

Postby doktor5000 » Mar 8th, '21, 22:47

Somehow got that mixed up, so this one is for mga8, and the other one was for mga7, got it.

You mentioned in systemsettings the output should be "Built-in Audio Analog Stereo" although in your output the only sink seems the be an HDMI one, no analog one.

For a comparison, this is from mga8, where analog is my default output and HDMI is available as lower priority one.

Code: Select all
[doktor5000@Mageia8]─[21:36:40]─[~] pacmd list-sinks | grep -iE "name:|priority"
        name: <alsa_output.pci-0000_00_1b.0.analog-stereo>
        priority: 9039
                analog-output-lineout: Line Out (priority 9000, latency offset 0 usec, available: yes)
                analog-output-headphones: Headphones (priority 9900, latency offset 0 usec, available: no)
        name: <alsa_output.pci-0000_01_00.1.hdmi-stereo>
        priority: 9030
                hdmi-output-0: HDMI / DisplayPort (priority 5900, latency offset 0 usec, available: yes)


When I check your output, the active profile is currently
active profile: <output:hdmi-stereo>


You may want to recheck with e.g. pavucontrol-qt and change the profile for the internal audio to something else and then back to analog stereo output.

Would also help if you could a screenshot from the output devices tab and from the configuration tab from pavucontrol-qt.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16739
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Sound broken in Mageia 8

Postby mla » Mar 8th, '21, 23:31

Yes, this one is for 8, the other is for 7.
Have used pavucontrol-qt which under the configuration tab shows all the missing entries, but marks them as "(unavailable)". So I tried setting it to "Analog Stereo Duplex (unavailable)" and, blow me, sound now works! Going back to "System Settings"->Audio, the profile is now blank, while the pull-down menu still only have the short list I reported.

Here are the requested screenshots:

Image

NB: There are no other entries on the pull-down devices menu

Image

And here's the Audio one:

Image

Essentially, something gets confused and falsely claims the duplex (etc) profiles to be unavailable, so that they don't get included in the defaul settings or the pull down menus of opssible settings.

So, thanks for your help, sound now works (but might disappear here too :-)). Should I mark this thread SOLVED and report a bug?
Last edited by mla on Mar 9th, '21, 12:41, edited 2 times in total.
mla
 
Posts: 292
Joined: Sep 16th, '11, 16:10

Re: Sound broken in Mageia 8

Postby doktor5000 » Mar 8th, '21, 23:55

You may want to check the screenshots again, seems the CDN does not like deeplinks.

Well, you should keep it in mind. If it's reproducible and if you get this issue with a default installation (without any old/migrated settings in /home etc.) then you should report it.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16739
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Sound broken in Mageia 8

Postby mla » Mar 9th, '21, 00:45

Hm... As I submitted it, I was returned to the thread and shown properly all three .png URLs. But now they don't show any more. Oh well, just try

https://mipmip.org/hromada/OutputDevices.png
https://mipmip.org/hromada/Cfg.png
https://mipmip.org/hromada/Audio.png

BTW, on Mageia 7 pavucontrol-qt shows all those entries having status "(unknown)" rather than "(unavailable)". So I suspect Mag8 is just being stricter and reckons that unknown must mean unavailable. But I'll experiment with a separate account tomorrow to rule out any legacy personal settings. Otherwise the install was a clean one. I never upgrade from the previous version -- had too many odd problems in the past.
mla
 
Posts: 292
Joined: Sep 16th, '11, 16:10

Re: Sound broken in Mageia 8

Postby mla » Mar 9th, '21, 00:50

What the!?... Those images are now there in the original post as intended! Why???Hmm... What did I do... I think I started another reply, looked at the preview, decided not to bother and just hit the back button. Or something like that. Something is bugged in this interface. :-(
mla
 
Posts: 292
Joined: Sep 16th, '11, 16:10

Re: Sound broken in Mageia 8

Postby doktor5000 » Mar 9th, '21, 01:06

mla wrote:What the!?... Those images are now there in the original post as intended! Why???

The pictures are hosted at a CDN, so it displays differently for you then somebody else. This is what I get:

Error 1011 Ray ID: 62cfb663ee8e4174 • 2021-03-08 23:06:09 UTC
Access denied
What happened?
The owner of this website (mipmip.org) does not allow hotlinking to that resource (/hromada/OutputDevices.png).
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16739
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Sound broken in Mageia 8

Postby mla » Mar 9th, '21, 12:26

No idea. I tested those links before posting them and have just tested them again -- they work for me in Firefox, Chrome and Konqueror. And Curiously enough, as I click on the links in my post above and then go back to this thread, the images that didn't work in the previous post get embedded one by one.

Ah... Hang on. I just got a similar error on the Audio.png file -- but only in Firefox. Chrome and Konqueror have no problem. And it is a Cloudflare error message, not the mipmip.org server one, so I've switched Cloudflare proxy off and purged its cache as well, which should solve the problem, whatever it is. Try again?
mla
 
Posts: 292
Joined: Sep 16th, '11, 16:10

Re: Sound broken in Mageia 8

Postby mla » Mar 9th, '21, 13:45

OK. Problem confirmed on a completely clean install of Mageia 8 and a completely new account. Unfortunately, the audio settings revert to the non-working ones every time one logs in. So I am marking this thread as WORKAROUND and will be submitting a bug report.

For the benefit of anybody else with the same problem... The work-around is: having logged in, use the pavucontrol-qt command, go to the Configuration tab and on the pull-down menu select the appropriate profile, ignoring the fact that it is tagged as "(unavailable)".( The System Settings app will now show under the Audio's Advanced tab the current profile as completely blank -- ignore this; clicking on the "Front left" and "Front right" test buttons should show audio working.)
mla
 
Posts: 292
Joined: Sep 16th, '11, 16:10

Re: Sound broken in Mageia 8 (WORKAROUND)

Postby doktor5000 » Mar 9th, '21, 23:30

Yeah, screenshots are working now and show just fine.

Please post the link to the bugreport once you filed it, for others to follow up, thanks in advance.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16739
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Sound broken in Mageia 8 (WORKAROUND)

Postby mla » Mar 9th, '21, 23:44

Bug report is https://bugs.mageia.org/show_bug.cgi?id=28565, but it turns out that my mga7 sound problem is, after all, closely related. Your question whether it was the same system was not dumb at all! :-) I am about to update the other topic (https://forums.mageia.org/en/viewtopic.php?f=26&t=13975) shortly.
mla
 
Posts: 292
Joined: Sep 16th, '11, 16:10

Re: Sound broken in Mageia 8 (WORKAROUND)

Postby mla » Mar 11th, '21, 16:59

Here's a *much* better work-around for mga8, which prevents the audio profile reverting to a bad one on every login. (But the mga7 problem of it reverting occasionally within a login session, which may still be there on mga8 too, is unaffected by this workaround).

1. Get audio working by using pavucontrol-qt, to force the correct profile, even if it is marked as "unavailable".
2. Do "pacmd list-cards | grep -e name: -e active" to get your current card and profile names (just strip off the angle brackets from them).
3. Test the intended setting by "pactl <card_name> <profile_name>" and if this works
4. As root, add to the file /etc/pulse/default.pa the line "set-card-profile <card_name> <profile_name>"

So e.g. in my case, steps 2 and 3 are:

Code: Select all
[ATH ~] pacmd list-cards | grep -e name: -e active
        name: <alsa_card.pci-0000_00_1f.3>
        active profile: <output:analog-stereo+input:analog-stereo>
[ATH ~] pactl set-card-profile alsa_card.pci-0000_00_1f.3 output:analog-stereo+input:analog-stereo

then, as root

Code: Select all
echo set-card-profile alsa_card.pci-0000_00_1f.3 output:analog-stereo+input:analog-stereo >>/etc/pulse/default.pa
mla
 
Posts: 292
Joined: Sep 16th, '11, 16:10


Return to Sound

Who is online

Users browsing this forum: No registered users and 1 guest