Input microphone from headset does not work [SOLVED]

Input microphone from headset does not work [SOLVED]

Postby girlando » Jun 15th, '20, 11:11

Mageia 7. I discovered this only recently, when due to shutdown have to use headphones. Output sound works perfectly, but input microphone in muted and cannot be activated in pulseaudio (see picture).
audioInput.png
screenshot of pavucontrol for input
audioInput.png (15.02 KiB) Viewed 885 times

Some relevant info from alsa.conf:
Manufacturer: ASUSTeK COMPUTER INC.
Product Name: UN68U
Product Version: To be filled by O.E.M.
Firmware Version: 0412
Board Vendor: ASUSTeK COMPUTER INC.
Board Name: UN68U
-----------------!!Soundcards recognised by ALSA
0 [PCH ]: HDA-Intel - HDA Intel PCH
HDA Intel PCH at 0xf7340000 irq 147
!!PCI Soundcards installed in the system
00:1f.3 Audio device [0403]: Intel Corporation Sunrise Point-LP HD Audio [8086:9d71] (rev 21)
Subsystem: ASUSTeK Computer Inc. Device [1043:864d]
ARECORD
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CX20751/2 Analog [CX20751/2 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0


Trying searching online gave no help. I do not think it is a bug, just my unability to get the system working. On my ASUS laptop everything is OK.
Last edited by girlando on Jun 20th, '20, 21:24, edited 1 time in total.
girlando
 
Posts: 11
Joined: Jun 2nd, '11, 10:30

Re: Input microphone from headset does not work

Postby doktor5000 » Jun 15th, '20, 16:01

girlando wrote:when due to shutdown have to use headphones. Output sound works perfectly, but input microphone in muted and cannot be activated in pulseaudio (see picture).


Could you please rephrase that description, or add some explanation please. Is the problem that the microfone is muted, and that you want to use the microfone from your headset ?

Also, how is the headset physically connected, with only one 3.5mm jack for both speakers+microfone, or 2 x 3.5mm jacks. Or differently, e.g. via bluetooth or ... ?
Also, what laptop model do you have ?
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16131
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Input microphone from headset does not work

Postby girlando » Jun 16th, '20, 20:53

Sorry for the bad description. I was only saying that I never tested the microphone on the computer, only speakers The one which gives problems is not a laptop, but a minicomputer ASUS "mini" based on the NUC platform by Intel (the model is written in my message but it is just a number). So it has not built in-audio, the connection is made via a headphone 3.5 mm connector, just like a normal laptop. The connection is only one 3.5mm jack for both speakers+microphone, and I have an adaptor to a two-jack headphones. I posted the picture with the pavucontrol to show that the connection to the microphone is active, if I disconnect the cable it says there are no devices connected.

The type of headphone is irrelevant. I borrowed one from my wife, and got the same result. I tested both the headphones on another computer, in this case a ASUS laptop, always with Mageia, and both headphones work perfectly. I do not think it is a problem of hardware on the ASUS mini, although of course I cannot be 100% sure. I have read that Conexant audio could give this kind of problem, but that was at least 10 years ago. Thank you for replying to my badly written message.
girlando
 
Posts: 11
Joined: Jun 2nd, '11, 10:30

Re: Input microphone from headset does not work

Postby girlando » Jun 16th, '20, 21:47

I add that the laptop where everything is working has a different soundcard: PCH, HDA Intel PCH, device 0: ALC3236 Analog [ALC3236 Analog] whereas in the one which gives problem is PCH [HDA Intel PCH], device 0: CX20751/2 Analog [CX20751/2 Analog].
girlando
 
Posts: 11
Joined: Jun 2nd, '11, 10:30

Re: Input microphone from headset does not work

Postby doktor5000 » Jun 16th, '20, 22:33

Ok, so only the microphone is not working, from what I understood. Can you please post the output as regular user of the following commands

Code: Select all
grep -i codec /proc/asound/card*/codec*
LC_ALL=C pacmd ls
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16131
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Input microphone from headset does not work

Postby girlando » Jun 17th, '20, 09:36

Code: Select all
grep -i codec /proc/asound/card*/codec*
/proc/asound/card0/codec#0:Codec: Conexant CX20751/2
/proc/asound/card0/codec#2:Codec: Intel Kabylake HDMI


Notice: I have a HDMI monitor, but without speakers, so I use it only for video, and I bought a separate pair of speakers which are connected to the audio output. For the microphone I change the audio connection to the headset, of course.

The long output of the second command is:
LC_out.txt
(22.31 KiB) Downloaded 28 times
Last edited by isadora on Jun 17th, '20, 09:37, edited 1 time in total.
Reason: Placed command-output in between [CODE]-tags for better readability ;)
girlando
 
Posts: 11
Joined: Jun 2nd, '11, 10:30

Re: Input microphone from headset does not work

Postby doktor5000 » Jun 17th, '20, 17:35

FWIW, can you test the microphone on any other device, so you know it's working? From what I understood, you don't know whether the microphone itself is working or not.
Also, how did you test the microphone, using what application?

Apart from that, please also add the output of
Code: Select all
lspcidrake -v
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16131
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Input microphone from headset does not work

Postby girlando » Jun 17th, '20, 17:59

The microphone is working, I tested on another computer (see my previous message), and I also tested two different microphones on this one. Same result. The microphone is seen by pulseaudio, by I cannot unmute it.
---------------------------------------------------
Code: Select all
lspcidrake -v:

i2c_i801        : Intel Corporation|Sunrise Point-LP SMBus [SERIAL_SMBUS] (vendor:8086 device:9d23 subv:1043 subd:8694) (rev: 21)
xhci_pci        : Intel Corporation|Sunrise Point-LP USB 3.0 xHCI Controller [SERIAL_USB] (vendor:8086 device:9d2f subv:1043 subd:8694) (rev: 21)
Card:Intel 810 and later: Intel Corporation|UHD Graphics 620 [DISPLAY_VGA] (vendor:8086 device:5917 subv:1043 subd:8694) (rev: 07)
unknown         : Intel Corporation|Sunrise Point-LP PCI Express Root Port #5 [BRIDGE_PCI] (vendor:8086 device:9d14) (rev: f1)
e1000e          : Intel Corporation|Ethernet Connection I219-V [NETWORK_ETHERNET] (vendor:8086 device:1570 subv:1043 subd:8672) (rev: 21)
unknown         : Intel Corporation|Sunrise Point-LP PCI Express Root Port #9 [BRIDGE_PCI] (vendor:8086 device:9d18) (rev: f1)
unknown         : Intel Corporation|Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers [BRIDGE_HOST] (vendor:8086 device:5914 subv:1043 subd:8694) (rev: 08)
snd_hda_intel   : Intel Corporation|Sunrise Point-LP HD Audio [MULTIMEDIA_AUDIO_DEV] (vendor:8086 device:9d71 subv:1043 subd:864d) (rev: 21)
xhci_pci        : ASMedia Technology Inc.|ASM2142 USB 3.1 Host Controller [SERIAL_USB] (vendor:1b21 device:2142 subv:1043 subd:8756)
mei_me          : Intel Corporation|Sunrise Point-LP CSME HECI #1 [COMMUNICATION_OTHER] (vendor:8086 device:9d3a subv:1043 subd:8694) (rev: 21)
iwlwifi         : Intel Corporation|Wireless 8265 / 8275 [NETWORK_OTHER] (vendor:8086 device:24fd subv:8086 subd:0010) (rev: 78)
unknown         : Intel Corporation|Sunrise Point LPC Controller/eSPI Controller [BRIDGE_ISA] (vendor:8086 device:9d4e subv:1043 subd:8694) (rev: 21)
unknown         : Intel Corporation|Sunrise Point-LP PCI Express Root Port #1 [BRIDGE_PCI] (vendor:8086 device:9d10) (rev: f1)
unknown         : Intel Corporation|Sunrise Point-LP PMC [MEMORY_OTHER] (vendor:8086 device:9d21 subv:1043 subd:8694) (rev: 21)
unknown         : Intel Corporation|Sunrise Point-LP SATA Controller [AHCI mode] [STORAGE_SATA] (vendor:8086 device:9d03 subv:1043 subd:8694) (rev: 21)
unknown         : Samsung Electronics Co Ltd|NVMe SSD Controller SM961/PM961 (vendor:144d device:a804 subv:144d subd:a801)
hub             : Linux 5.6.14-desktop-2.mga7 xhci-hcd|xHCI Host Controller [Hub|Unused|Full speed (or root) hub] (vendor:1d6b device:0002)
hub             : Genesys Logic, Inc.|USB2.0 Hub [Hub|Unused|Full speed (or root) hub] (vendor:05e3 device:0608)
usbhid          : Logitech|USB Receiver [Human Interface Device|Boot Interface Subclass|Keyboard] (vendor:046d device:c534)
rtsx_usb        : Generic|USB2.0-CRW (vendor:0bda device:0129)
btusb           : Intel Corp.|Unknown [Wireless|Radio Frequency|Bluetooth] (vendor:8087 device:0a2b)
hub             : Linux 5.6.14-desktop-2.mga7 xhci-hcd|xHCI Host Controller [Hub|Unused|Full speed (or root) hub] (vendor:1d6b device:0003)
hub             : Linux 5.6.14-desktop-2.mga7 xhci-hcd|xHCI Host Controller [Hub|Unused|Full speed (or root) hub] (vendor:1d6b device:0002)
hub             : Linux 5.6.14-desktop-2.mga7 xhci-hcd|xHCI Host Controller [Hub|Unused|Full speed (or root) hub] (vendor:1d6b device:0003)
hid_generic     : Logitech USB Receiver
hid_generic     : Logitech USB Receiver
hid_generic     : Logitech Wireless Keyboard PID:4023
hid_generic     : Logitech Wireless Mouse
Last edited by isadora on Jun 17th, '20, 18:20, edited 1 time in total.
Reason: Placed command-output in between [CODE]-tags for better readability ;)
girlando
 
Posts: 11
Joined: Jun 2nd, '11, 10:30

Re: Input microphone from headset does not work

Postby doktor5000 » Jun 17th, '20, 23:03

girlando wrote:snd_hda_intel : Intel Corporation|Sunrise Point-LP HD Audio [MULTIMEDIA_AUDIO_DEV] (vendor:8086 device:9d71 subv:1043 subd:864d) (rev: 21)

So it is driven by snd_hda_intel. Although I can't find any quirks for your codec Conexant CX20751 here: https://www.kernel.org/doc/html/latest/ ... odels.html

Could you also post the output as root of
Code: Select all
journalctl -ab|grep -iE "snd|hda"


For the muted part, it doesn't look muted from the pacmd output. Although you could still try to run alsamixer as root and check if it says "MM" for muted below the mixer channel for the microphone, and try to unmute it there or play with the volume level.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16131
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Input microphone from headset does not work

Postby girlando » Jun 17th, '20, 23:26

journalctl -ab|grep -i snd_hda_intel

sandok kernel: snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])

I had already tried alsamixer, the microphone was unmuted (both as root or as a normal user. Strangely enough, I cannot mute it by pressing the M key. and the pavucontrol always says it is muted (whereas I can control the output both by alsamixer or pavucontrol).


During this time I remembered I had a old "legacy" 32 bit BODHI operating system (live) on a USB key. I booted from that USB, and the microphone works, I can mute/unmoute, record voice etc.
So I am sure now that it is a software problem, perhaps at the kernel level. Should I open a bug ?
girlando
 
Posts: 11
Joined: Jun 2nd, '11, 10:30

Re: Input microphone from headset does not work

Postby doktor5000 » Jun 17th, '20, 23:52

girlando wrote:journalctl -ab|grep -i snd_hda_intel

Check again it's
Code: Select all
journalctl -ab|grep -iE "snd|hda"


girlando wrote:During this time I remembered I had a old "legacy" 32 bit BODHI operating system (live) on a USB key. I booted from that USB, and the microphone works, I can mute/unmoute, record voice etc.
So I am sure now that it is a software problem, perhaps at the kernel level. Should I open a bug ?

kernel drivers can change over time, and default settings could also be different. I'm trying to figure out as what this codec is detected.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16131
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Input microphone from headset does not work

Postby girlando » Jun 20th, '20, 08:37

journalctl -ab|grep -iE "snd|hda"

mageia.txt
(1.72 KiB) Downloaded 24 times
girlando
 
Posts: 11
Joined: Jun 2nd, '11, 10:30

Re: Input microphone from headset does not work

Postby girlando » Jun 20th, '20, 08:49

I decided to test a another operating system, similar to Mageia. So I downloaded Fedora live, kernel 5.6.6-300. There, microphone works. The only difference is that Fedora is using Gnome, whereas with Mageia I am using Cinnamon. But I do not think it makes a difference, Icewm with Mageia is the same (mic not working). I post the output of journalctl -ab|grep -iE "snd|hda" with the Fedora op, which is slightly different, in case it can provide clues:

fedora.txt
(1.94 KiB) Downloaded 28 times


I am definitely thinking is a bug, an old one probably remained undetected
girlando
 
Posts: 11
Joined: Jun 2nd, '11, 10:30

Re: Input microphone from headset does not work

Postby doktor5000 » Jun 20th, '20, 14:29

Well, the soundcard is detected exactly the same both under Mageia and Fedora

Code: Select all
Jun 20 08:05:55 localhost kernel: snd_hda_codec_conexant hdaudioC0D0: CX20751/2: BIOS auto-probing.
Jun 20 08:05:55 localhost kernel: snd_hda_codec_conexant hdaudioC0D0: autoconfig for CX20751/2: line_outs=1 (0x16/0x0/0x0/0x0/0x0) type:hp
Jun 20 08:05:55 localhost kernel: snd_hda_codec_conexant hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
Jun 20 08:05:55 localhost kernel: snd_hda_codec_conexant hdaudioC0D0:    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
Jun 20 08:05:55 localhost kernel: snd_hda_codec_conexant hdaudioC0D0:    mono: mono_out=0x0
Jun 20 08:05:55 localhost kernel: snd_hda_codec_conexant hdaudioC0D0:    inputs:
Jun 20 08:05:55 localhost kernel: snd_hda_codec_conexant hdaudioC0D0:      Mic=0x19


You could try to fiddle around with hdajackretask, as e.g. explained here: https://forums.linuxmint.com/viewtopic. ... 3#p1629503
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16131
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Input microphone from headset does not work

Postby girlando » Jun 20th, '20, 16:21

Solved ! Thank you Doktor5000 for your time !
I read the post on linuxmint forum, but before trying hdajackretask (which I had already tried, but withouth knowing was I was doing and why), I read that sometimes one could solve the problem by deleting .conf/pulse, and letting the system reconfigure pulse automatically. And this simply worked. The reason is that I never used the mic before, so the configuration created without the microphone remained.

Thanks again
girlando
 
Posts: 11
Joined: Jun 2nd, '11, 10:30

Re: Input microphone from headset does not work

Postby isadora » Jun 20th, '20, 20:06

Would you please mark this topic [SOLVED]?
You can do so by editing the title/subject of the first message in the topic.
Place [SOLVED] in front of subject/title.

Thanks ahead. :)
..........bird from paradise..........

Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.
—Antoine de Saint-Exupéry
User avatar
isadora
 
Posts: 2616
Joined: Mar 25th, '11, 16:03
Location: Amsterdam, the Netherlands


Return to Sound

Who is online

Users browsing this forum: No registered users and 1 guest