Page 1 of 1

Mageia 7 - no USB sound [RESOLVED]

PostPosted: Jul 4th, '19, 13:23
by mla
Have installed Mageia 7 and all looks well, except that my USB speakers now produce no sound. Using PilseAudio volume control, I made sure (under Configuration tab) that USB audio is set to "Digital Stereo (IEC958) Output" (the only other option being "off" and that all other possibilities are set to off. Under both Output Devices tab and the Playback one, I can see sound apparently being produced, but the speakers remain silent.

To make sure there were no legacy issues, I moved ~/.config/pulse out of the way, let the system create a new one and again made sure things are set up as per above. Still no sound.

Any suggestions?

Re: Mageia 7 - no USB sound [RESOLVED]

PostPosted: Jul 5th, '19, 15:07
by mla
OK, problem resolved (though I wouldn't say "solved" :-)). Today, under the "Configuration" tab, USB AUDIO gives me three options rather than two it did yesterday: "Analog Stereo Output" (which is new), "Digital Stereo (IEC958) Output" and "Off". Choosing analogue solves the problem. I swear (but cannot prove) that option was not there yesterday. All I did in between was to boot Mageia 6 to make sure that USB sound worked. Whether this somehow kicked something hardware-wise, I have no idea. I just hate these problems that mutate as you investigate them. :-(