[SOLVED]Problem with libsecret-tools 64 bit in Mageia 5

[SOLVED]Problem with libsecret-tools 64 bit in Mageia 5

Postby mackowiakp » Sep 26th, '17, 10:37

I installed current Skypeforlinux via YUM by adding Skype repo in /etc/yum.repos.d dir. Skype now is easily upgraded via YUM (not via urpmi) and works correctly.
Now I want to install one in the same way in M5 (64 bit). So, get-skype was removed, YUM facilities installed and added repos for Adobe reader, Insync and Skype.
Adobe and Insync packages are installed that way correctly and updated correctly from time to time.
But when I try to install Skypeforlinux, it rapports that there is no libsecret installed. But it is installed already in the system:

Code: Select all
[root@gosia-aio ~]# urpmi libsecret-tools
Pakiet libsecret-tools-0.18-4.mga5.x86_64 jest już zainstalowany w systemie


Translation -> package libsecret-tools-0.18-4.mga5.x86_64 is already installed in the system.

Does anybody know what the problem could be?
Last edited by mackowiakp on Nov 3rd, '17, 07:19, edited 1 time in total.
Linux is like wigwam. No Windows, no Gates but Apache inside

WARNING ! The administrator has the right to refuse to install WINDOWS, invoking the conscience clause
mackowiakp
 
Posts: 523
Joined: May 23rd, '13, 07:32
Location: Gdynia, Poland

Re: Problem with libsecret-tools 64 bit in Mageia 5

Postby doktor5000 » Sep 26th, '17, 12:41

Skype is looking for libsecret, but you only have libsecret-tools installed, pretty simple.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14320
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Problem with libsecret-tools 64 bit in Mageia 5

Postby mackowiakp » Sep 26th, '17, 16:42

But lib64secret1 is installed too:

Code: Select all
[root@gosia-aio ~]# ls /usr/lib64/libsecret-1.so.0*
/usr/lib64/libsecret-1.so.0@  /usr/lib64/libsecret-1.so.0.0.0*
[root@gosia-aio ~]# urpmi lib64secret1_0
Pakiet lib64secret1_0-0.18-4.mga5.x86_64 jest już zainstalowany w systemie

Translations -> Package xxx is already installed in system
Linux is like wigwam. No Windows, no Gates but Apache inside

WARNING ! The administrator has the right to refuse to install WINDOWS, invoking the conscience clause
mackowiakp
 
Posts: 523
Joined: May 23rd, '13, 07:32
Location: Gdynia, Poland

Re: Problem with libsecret-tools 64 bit in Mageia 5

Postby Ken-Bergen » Sep 26th, '17, 22:30

As far as I know Skype is still 32bit so you need libsecret1_0 which can be installed along side of lib64secret1_0
Ken
Ken-Bergen
 
Posts: 1010
Joined: Mar 30th, '11, 02:45
Location: Chilliwack, BC, Canada

Re: Problem with libsecret-tools 64 bit in Mageia 5

Postby mackowiakp » Sep 27th, '17, 08:18

As M$ community stands, there is no 32 bit Linux ver avaliable starting from 5.x.x.
LINK -> https://answers.microsoft.com/en-us/skype/forum/skype_linux-skype_startms/no-more-skype-for-linux-32-bits/8d2ed541-c1ab-4571-a352-760a8c16368c?auth=1
On working system (M6) there is no libsecret1_0 installed (32 bit). But I installed this library for test purposes on M5 and it does not help. Still no lucky. So I try to install it manually not via YUM.

Code: Select all
[root@gosia-aio TMP]# urpmi ./skypeforlinux-64.rpm
Wybrany pakiet nie może zostać zainstalowany:
skypeforlinux-5.5.0.1-1.x86_64 (z powodu niesatysfakcjonującego pakietu libsecret)

Translation -> Selected packet  can not be installed
skype...... (Because of the unsatisfactory libsecret package)


The ver of libsecret on working system (M6) is 0.18.5 while on not working system (M5) is 0.18
Linux is like wigwam. No Windows, no Gates but Apache inside

WARNING ! The administrator has the right to refuse to install WINDOWS, invoking the conscience clause
mackowiakp
 
Posts: 523
Joined: May 23rd, '13, 07:32
Location: Gdynia, Poland

Re: Problem with libsecret-tools 64 bit in Mageia 5

Postby doktor5000 » Sep 27th, '17, 16:29

That is because no package provides the facility/token "libsecret". You could have easily posted that in your OP, and we could have told you that much earlier.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14320
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Problem with libsecret-tools 64 bit in Mageia 5

Postby Bronto » Oct 27th, '17, 11:18

I have the same problem! I have Mageia 5 x64.. And I can not install new skype version on it. I see the error: "A requested package cannot be installed: skypeforlinux-5.5.0.1-1.x86_64 (due to unsatisfied libsecret)"... I'm not native English person and not so professional in Linux system knowledgement.. So can anyone explain this situation in more accessible manner? Is there any chance to install new skype on Mageia 5? And if yes please explain completely step by step the correct way to install it!
Bronto
 
Posts: 5
Joined: Mar 2nd, '17, 18:18

Re: Problem with libsecret-tools 64 bit in Mageia 5

Postby doktor5000 » Oct 27th, '17, 19:14

You should be able to install skype via urpmi --allow-nodeps skypeforlinux-5.5.0.1-1.x86_64.rpm but unless it can use the older libsecret in M5 there will probably be no integration with your password manager (kwallet/seahorse) but skype itself should work. I believe I tried that out on M5 and it worked fine.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14320
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Problem with libsecret-tools 64 bit in Mageia 5

Postby Bronto » Oct 30th, '17, 13:10

doktor5000 wrote:You should be able to install skype via urpmi --allow-nodeps skypeforlinux-5.5.0.1-1.x86_64.rpm but unless it can use the older libsecret in M5 there will probably be no integration with your password manager (kwallet/seahorse) but skype itself should work. I believe I tried that out on M5 and it worked fine.

Thank you very much! It worked out!
Bronto
 
Posts: 5
Joined: Mar 2nd, '17, 18:18

Re: Problem with libsecret-tools 64 bit in Mageia 5

Postby mackowiakp » Nov 3rd, '17, 07:19

Solved ! THX Doktor5000
Linux is like wigwam. No Windows, no Gates but Apache inside

WARNING ! The administrator has the right to refuse to install WINDOWS, invoking the conscience clause
mackowiakp
 
Posts: 523
Joined: May 23rd, '13, 07:32
Location: Gdynia, Poland

Re: Problem with libsecret-tools 64 bit in Mageia 5

Postby flink » Nov 27th, '17, 13:29

doktor5000 wrote:You should be able to install skype via urpmi --allow-nodeps skypeforlinux-5.5.0.1-1.x86_64.rpm


I have done this in Mageia 5.

Code: Select all
[franz@localhost Skype]$ sudo urpmi --allow-nodeps skypeforlinux-64.rpm 
Achtung: Die --allow-nodeps-Option wird genutzt. Es können einige seltsame Probleme auftreten


skypeforlinux-64.rpm wird installiert
Installation fehlgeschlagen:
   libsecret wird benötigt von skypeforlinux-8.11.0.4-1.x86_64
Soll eine Installation ohne Abhängigkeitstest versucht werden? (j/N) j
Vorbereiten …                    #######################################################################
      1/1: skypeforlinux         #######################################################################
Redirecting to /bin/systemctl start atd.service
error: unknown package manager
Warnung: %post(skypeforlinux-8.11.0.4-1.x86_64) Scriptlet fehlgeschlagen, Beenden-Status 1
ERROR: 'script' failed for skypeforlinux-8.11.0.4-1


It reports an error. However the Skype icon is there now and I can start Skype.
flink
 
Posts: 50
Joined: Mar 3rd, '12, 19:23

Re: [SOLVED]Problem with libsecret-tools 64 bit in Mageia 5

Postby mackowiakp » Nov 27th, '17, 13:59

Yep. The same here. But in M6 there is no such problems. But there is a lot of others... ;-)
I use YUM to upgrade non-Mageia repo packages. It works both in M5 and in M6
Linux is like wigwam. No Windows, no Gates but Apache inside

WARNING ! The administrator has the right to refuse to install WINDOWS, invoking the conscience clause
mackowiakp
 
Posts: 523
Joined: May 23rd, '13, 07:32
Location: Gdynia, Poland


Return to Sound

Who is online

Users browsing this forum: No registered users and 1 guest

cron