[SOLVED] Sound on Asus G752VY --> white noise in headphones

[SOLVED] Sound on Asus G752VY --> white noise in headphones

Postby schnuck » Aug 4th, '17, 19:16

Hello List,

Purchased an Asus G752VY (Gamer Laptop) and installed Mageia 6 on it.
By far the most annoying problem is: a high pitch noise in the headphones.
It's just only in the headphones. It starts when during booting the soundcard is initialized and stops when the system is stopped.
It is completely independent from the volume or whether there is any sound output.

I am using ALSA to play sound, but it's the same in pulseaudio, of course.

The soundcard is a Realtek ALC668.
Any ideas?

Some info gathered by alsa-info.sh:

Code: Select all
Kernel release:    4.9.40-desktop-1.mga6
!!ALSA Version
!!------------

Driver version:     k4.9.40-desktop-1.mga6
Library version:    1.1.4.1
Utilities version:  1.1.4
!!Loaded ALSA modules
!!-------------------

snd_hda_intel
snd_hda_intel

!!Soundcards recognised by ALSA
!!-----------------------------

 0 [PCH            ]: HDA-Intel - HDA Intel PCH
                      HDA Intel PCH at 0xda128000 irq 327
 1 [NVidia         ]: HDA-Intel - HDA NVidia
                      HDA NVidia at 0xdc080000 irq 17

!!PCI Soundcards installed in the system
!!--------------------------------------

00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
01:00.1 Audio device: NVIDIA Corporation GM204 High Definition Audio Controller

!!Modprobe options (Sound related)
!!--------------------------------

snd_ac97_codec: power_save=1
snd_hda_intel: model=auto


Greetings
Last edited by schnuck on Aug 5th, '17, 21:11, edited 2 times in total.
schnuck
 
Posts: 20
Joined: Nov 25th, '12, 22:48
Location: Münster / Germany

Re: Sound on Asus G752VY --> white noise in headphones

Postby doktor5000 » Aug 4th, '17, 19:40

Do you have any speaker system which offers a headphone output that you could try for testing? Maybe this is just a feedback loop?

But there seems to be a widespread issue about such white / hissing noise for ALC668, see a solution here: http://en.community.dell.com/support-fo ... 4#20665844
See also https://xps13-9333.appspot.com/#background_noise or https://bugs.launchpad.net/ubuntu/+sour ... ug/1252733

There's also another really creative workaround here: https://askubuntu.com/a/908829/329633

If that does not help, here are some other workarounds for Asus models: https://ubuntuforums.org/showthread.php?t=2312163
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14432
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Sound on Asus G752VY --> white noise in headphones

Postby schnuck » Aug 5th, '17, 20:51

doktor5000 - thank you very much.
Most of the hints I had already found and tried.
But the Asus specific link https://ubuntuforums.org/showthread.php?t=2312163 finally brought the solution.

The trick is to add
options snd-hda-intel model=dell-headset-multi
to the file /etc/modprobe.d/alsa-base.conf

This finally cut off this loud white noise.
So many thanks for your hints.
schnuck
 
Posts: 20
Joined: Nov 25th, '12, 22:48
Location: Münster / Germany

Re: Sound on Asus G752VY --> white noise in headphones

Postby isadora » Aug 5th, '17, 21:10

Please schnuck, don't forget to mark the topic [SOLVED].
You can do so, by editing the subject/title in the first message in this topic.
Write [SOLVED] to the left of subject/title, thanks ahead. ;)
..........bird from paradise..........

Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.
—Antoine de Saint-Exupéry
User avatar
isadora
 
Posts: 2372
Joined: Mar 25th, '11, 16:03
Location: Amsterdam, the Netherlands

Re: Sound on Asus G752VY --> white noise in headphones

Postby schnuck » Aug 5th, '17, 21:10

On a side note: also the muting of the speakers when the headphones are plugged in started working now.
So sound is working as expected now.
;-)
schnuck
 
Posts: 20
Joined: Nov 25th, '12, 22:48
Location: Münster / Germany

Re: [SOLVED] Sound on Asus G752VY --> white noise in headpho

Postby schnuck » Aug 29th, '17, 13:43

Just found out that after suspend (STR) the problem comes up again.
So I might have to force the re-initializing of the sound module after that?
Or I might have to force an unload of the module while it's sleeping?

Hope someone enlightens me what to do.
TIA
schnuck
 
Posts: 20
Joined: Nov 25th, '12, 22:48
Location: Münster / Germany


Return to Sound

Who is online

Users browsing this forum: No registered users and 1 guest