Realtek 8822be Wifi issue in Magiea 8

Realtek 8822be Wifi issue in Magiea 8

Postby paultgg » Mar 5th, '21, 21:12

Hi, since switching to Magiea 8 (clean install, not upgrade), my wifi has stopped working. Looks like it's not powering up properly? So far, I've tried disabling ACPI on boot, and updating the linux-firmware package from the git repo (it looks like there's a patch coming, I just haven't figured out where the patch is sitting so I can try to grab it and build whatever it's patching). Can't remember if I've tried anything else, so any and all tips are welcome!

Relevant bit of dmesg:
Code: Select all
[   12.119576] rtw_8822be 0000:07:00.0: can't change power state from D3hot to D0 (config space inaccessible)
[   12.120461] rtw_8822be 0000:07:00.0: mac power on failed
[   12.120478] rtw_8822be 0000:07:00.0: failed to power on mac
[   12.120490] rtw_8822be 0000:07:00.0: failed to setup chip efuse info
[   12.120503] rtw_8822be 0000:07:00.0: failed to setup chip information
[   12.141426] rtw_8822be 0000:07:00.0: Firmware version 27.2.0, H2C version 13
[   12.141465] rtw_8822be: probe of 0000:07:00.0 failed with error -114


...lspci...
Code: Select all
07:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8822BE 802.11a/b/g/n/ac WiFi adapter (rev ff) (prog-if ff)


...rfkill...
Code: Select all
ID TYPE      DEVICE                 SOFT      HARD
 0 wlan      ideapad_wlan      unblocked unblocked
 1 bluetooth ideapad_bluetooth   blocked unblocked
 2 bluetooth hci0                blocked unblocked


...and ip link... (wifi is missing)
Code: Select all
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: enp8s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP mode DEFAULT group default qlen 1000
    link/ether e8:6a:64:17:7d:95 brd ff:ff:ff:ff:ff:ff
Last edited by paultgg on Jul 8th, '21, 05:58, edited 2 times in total.
paultgg
 
Posts: 45
Joined: Sep 1st, '11, 19:30

Re: Realtek Wifi issue in Magiea 8

Postby doktor5000 » Mar 6th, '21, 00:21

What you could try is to blacklist the 2 ideapad modules, sometimes those modules can interfere with the soft kill switch functionality.

Apart from that, maybe you need to compile a newer version of the driver? Maybe you installed it yourself in the past ?

Closed match I could find and also pretty recent is https://github.com/lwfinger/rtw88/issues/37

Oh, and just to be sure - you do have the package rtlwifi-firmware installed ?
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16728
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Realtek Wifi issue in Magiea 8

Postby paultgg » Mar 6th, '21, 02:54

Thanks, Doktor. I do have rtlwifi-firmware installed. The only other change I've made is to update the rtw88 files from the link you posted. Still getting the same errors as above.

I did have this issue once before, years ago, and the solution ended up being to wait until a newer kernel/firmware/driver/whatever fixed it automatically. Might need to wait it out?
paultgg
 
Posts: 45
Joined: Sep 1st, '11, 19:30

Re: Realtek Wifi issue in Magiea 8

Postby doktor5000 » Mar 6th, '21, 12:34

paultgg wrote:The only other change I've made is to update the rtw88 files from the link you posted.

The link also provides some more context information about the error, and some module options to try out.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16728
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Realtek Wifi issue in Magiea 8

Postby paultgg » Mar 7th, '21, 03:05

The module change worked for me! Thanks once again, doktor!

Solution (from the link doktor posted):
In this file:
Code: Select all
/etc/modprobe.d/50-rtw_pci.conf


Add this line:
Code: Select all
options rtw_pci disable_aspm=y disable_msi=y


Disclaimer:
My wifi didn't work when I had that line, but didn't include "disable_msi=y". I don't know if you need both disable options together, or just disable_msi (I'll have to test that out), but having that line in that file (or creating that file with that line) seems to have worked for me.
Last edited by paultgg on Jul 8th, '21, 05:59, edited 3 times in total.
paultgg
 
Posts: 45
Joined: Sep 1st, '11, 19:30

Re: [SOLVED] Realtek Wifi issue in Magiea 8

Postby doktor5000 » Mar 7th, '21, 03:33

Better note that for the next fresh install ;)
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16728
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Realtek 8822be Wifi issue in Magiea 8

Postby paultgg » Jul 8th, '21, 06:05

Well, turns out the wifi stopped working after a time. It looks like the device was powering down, and that the driver is unable to power it back up. I also tried booting into Windows (I'm dual-booting), loading the OEM driver, and turning off the power-saving option in Device Manager, which I was hoping would sort out the firmware, but the device still starts up with power-saving enabled in Linux. I can turn it off using the iw command (something like "iw dev [device] set power_save off" or something like that), and it sometimes works for a while, but then a reboot kills it again. Sometimes the device won't even initialize properly (there's a point were the device name changes from "wlan0" to something like "wlsp0 etc" but there are times that doesn't happen, so the iw command can't be used.

If anyone has any brilliant ideas, let me know, but this realtek chipset may just be too flaky with Magiea.
paultgg
 
Posts: 45
Joined: Sep 1st, '11, 19:30

Re: Realtek 8822be Wifi issue in Magiea 8

Postby doktor5000 » Jul 8th, '21, 16:18

paultgg wrote:something like "iw dev [device] set power_save off" or something like that), and it sometimes works for a while, but then a reboot kills it again.

Well, you could add that into a script which is run on every boot, that would at least solve it after reboots.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16728
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Realtek 8822be Wifi issue in Magiea 8

Postby paultgg » Jul 9th, '21, 18:37

doktor5000 wrote:Well, you could add that into a script which is run on every boot, that would at least solve it after reboots.


Tried that, but I wasn't able to get it to work using a script place in a couple of different /etc/rc-whatever folders, so I figured I'd use sudo to have my normal account run the command whenever I logged in, but then I found the device doesn't always get renamed properly (from wlan0 to whatever else), so even if I ran the command successfully, it may still error out if it can't find the initial wlan0 device.
paultgg
 
Posts: 45
Joined: Sep 1st, '11, 19:30

Re: Realtek 8822be Wifi issue in Magiea 8

Postby dalto » Jul 9th, '21, 19:15

If you want something to run that has to happen every reboot, I would use a systemd service. If you set it to run before network-up.service, I think that would make sure the device was awake before it tried to bring the network up.

paultgg wrote:
doktor5000 wrote:Well, you could add that into a script which is run on every boot, that would at least solve it after reboots.


Tried that, but I wasn't able to get it to work using a script place in a couple of different /etc/rc-whatever folders

As a side note, what runs those, is there a systemd service that runs on boot?

EDIT: nevermind, they are converted into systemd units by systemd-sysv-generator. I guess I learned something today, sorry for the sidebar.
dalto
 
Posts: 13
Joined: Jun 20th, '21, 20:10


Return to Networking

Who is online

Users browsing this forum: No registered users and 1 guest