[SOLVED] Wifi networks not seen in Mageia 7

[SOLVED] Wifi networks not seen in Mageia 7

Postby meinsta » Jul 22nd, '20, 22:21

Hi,
I work on Mageia 7 and I am quite new to the system. Until some time ago I could connect both, wifi and wired networks but now it doesn't see any wifi network. Can you please help me?
Thanks in advance!
Last edited by meinsta on Jul 23rd, '20, 21:26, edited 1 time in total.
meinsta
 
Posts: 10
Joined: Apr 29th, '20, 23:08

Re: Wifi networks not seen in Mageia 7

Postby doktor5000 » Jul 22nd, '20, 22:48

Which desktop environment do you use currently? And please provide the output of the following commands:

Code: Select all
lspcidrake -v|grep -iE "wlan|wifi|wireless|net"
ps -ef|grep -v grep|grep -iE "net|wpa"


and, as root:
Code: Select all
ifconfig -a
rfkill list all
systemctl status network.service -a
journalctl -ab | grep -iE "fw|firmware|iwl|wifi|wire|80211"
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16072
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Wifi networks not seen in Mageia 7

Postby meinsta » Jul 22nd, '20, 23:20

Thank you for your fast answer!
I use Plasma.
Code: Select all
$ lspcidrake -v|grep -iE "wlan|wifi|wireless|net"
r8169           : Realtek Semiconductor Co., Ltd.|RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [NETWORK_ETHERNET] (vendor:10ec device:8168 subv:1043 subd:200f) (rev: 12)
iwlwifi         : Intel Corporation|Wireless 8260 [NETWORK_OTHER] (vendor:8086 device:24f3 subv:8086 subd:0010) (rev: 3a)
btusb           : Intel Corp.|Unknown [Wireless|Radio Frequency|Bluetooth] (vendor:8087 device:0a2b)
$ ps -ef|grep -v grep|grep -iE "net|wpa"
root        58     2  0 23:51 ?        00:00:00 [netns]
root      1577     1  0 23:51 ?        00:00:00 /usr/sbin/wpa_supplicant -B -i wlp2s0 -c /etc/wpa_supplicant.conf -D wext
root      1825     1  0 23:51 ?        00:00:00 /usr/bin/vmnet-bridge -s 6 -d /var/run/vmnet-bridge-0.pid -n 0
root      2465     1  0 23:51 ?        00:00:00 /usr/bin/vmnet-netifup -s 6 -d /var/run/vmnet-netifup-vmnet1.pid /dev/vmnet1 vmnet1
root      3490     1  0 23:51 ?        00:00:00 /usr/bin/vmnet-dhcpd -s 6 -cf /etc/vmware/vmnet1/dhcpd/dhcpd.conf -lf /etc/vmware/vmnet1/dhcpd/dhcpd.leases -pf /var/run/vmnet-dhcpd-vmnet1.pid vmnet1
root      3703     1  0 23:51 ?        00:00:00 /usr/bin/vmnet-natd -s 6 -m /etc/vmware/vmnet8/nat.mac -c /etc/vmware/vmnet8/nat/nat.conf
root      3975     1  0 23:51 ?        00:00:00 /usr/bin/vmnet-netifup -s 6 -d /var/run/vmnet-netifup-vmnet8.pid /dev/vmnet8 vmnet8
root      4464     1  0 23:51 ?        00:00:00 /usr/bin/vmnet-dhcpd -s 6 -cf /etc/vmware/vmnet8/dhcpd/dhcpd.conf -lf /etc/vmware/vmnet8/dhcpd/dhcpd.leases -pf /var/run/vmnet-dhcpd-vmnet8.pid vmnet8
radix    15723     1  1 23:53 ?        00:00:02 /usr/bin/perl /usr/bin/net_applet
root     18420 15685  0 23:53 ?        00:00:00 /usr/libexec/webkit2gtk-4.0/WebKitNetworkProcess 8 14
# ifconfig -a
enp3s0f1: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 70:4d:7b:b9:8c:06  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 32  bytes 2864 (2.7 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 32  bytes 2864 (2.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vmnet1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 172.16.83.1  netmask 255.255.255.0  broadcast 172.16.83.255
        inet6 fe80::250:56ff:fec0:1  prefixlen 64  scopeid 0x20<link>
        ether 00:50:56:c0:00:01  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 49  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

vmnet8: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.184.1  netmask 255.255.255.0  broadcast 192.168.184.255
        inet6 fe80::250:56ff:fec0:8  prefixlen 64  scopeid 0x20<link>
        ether 00:50:56:c0:00:08  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 46  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp2s0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether b8:8a:60:c5:fc:e2  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

# rfkill list all
0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: yes
        Hard blocked: no

# systemctl status network.service -a
● network.service - LSB: Bring up/down networking
   Loaded: loaded (/etc/rc.d/init.d/network; generated)
   Active: failed (Result: exit-code) since Wed 2020-07-22 23:51:45 IDT; 5min ago
     Docs: man:systemd-sysv-generator(8)
  Process: 1260 ExecStart=/etc/rc.d/init.d/network start (code=exited, status=1/FAILURE)

iul 22 23:51:45 localhost.localdomain network[1260]: Could not set interface wlp2s0 flags (UP): Operation not possible due to RF-kill
iul 22 23:51:45 localhost.localdomain network[1260]: ioctl[SIOCSIWENCODEEXT]: Invalid argument
iul 22 23:51:45 localhost.localdomain ifplugd(wlp2s0)[1579]: ifplugd 0.28 initializing.
iul 22 23:51:45 localhost.localdomain ifplugd(wlp2s0)[1579]: Using interface wlp2s0/B8:8A:60:C5:FC:E2 with driver <iwlwifi> (version: 5.6.14-desktop-2.mga7)
iul 22 23:51:45 localhost.localdomain ifplugd(wlp2s0)[1579]: Using detection mode: SIOCETHTOOL
iul 22 23:51:45 localhost.localdomain ifplugd(wlp2s0)[1579]: Initialization complete, link beat not detected.
iul 22 23:51:45 localhost.localdomain network[1260]: [  OK  ]
iul 22 23:51:45 localhost.localdomain systemd[1]: network.service: Control process exited, code=exited, status=1/FAILURE
iul 22 23:51:45 localhost.localdomain systemd[1]: network.service: Failed with result 'exit-code'.
iul 22 23:51:45 localhost.localdomain systemd[1]: Failed to start LSB: Bring up/down networking.

# journalctl -ab | grep -iE "fw|firmware|iwl|wifi|wire|80211"
iul 22 23:51:23 localhost.localdomain kernel: DMAR: [Firmware Bug]: No firmware reserved region can cover this RMRR [0x0000000078800000-0x000000007affffff], contact BIOS vendor for fixes
iul 22 23:51:23 localhost.localdomain kernel: DMAR: [Firmware Bug]: Your BIOS is broken; bad RMRR [0x0000000078800000-0x000000007affffff]
iul 22 23:51:23 localhost.localdomain kernel: Spectre V2 : Enabling Restricted Speculation for firmware calls
iul 22 23:51:23 localhost.localdomain kernel: ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
iul 22 23:51:23 localhost.localdomain kernel: [drm] Finished loading DMC firmware i915/skl_dmc_ver1_27.bin (v1.27)
iul 22 23:51:34 localhost.localdomain kernel: input: Asus Wireless Radio Control as /devices/LNXSYSTM:00/LNXSYBUS:00/ATK4002:00/input/input6
iul 22 23:51:34 localhost.localdomain kernel: tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover the entire command/response buffer. [mem 0xfed40000-0xfed4087f flags 0x200] vs fed40080 f80
iul 22 23:51:34 localhost.localdomain kernel: tpm_crb MSFT0101:00: [Firmware Bug]: ACPI region does not cover the entire command/response buffer. [mem 0xfed40000-0xfed4087f flags 0x200] vs fed40080 f80
iul 22 23:51:34 localhost.localdomain kernel: cfg80211: Loading compiled-in X.509 certificates for regulatory database
iul 22 23:51:34 localhost.localdomain kernel: cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
iul 22 23:51:34 localhost.localdomain kernel: elan_i2c i2c-ELAN1000:00: Elan Touchpad: Module ID: 0x0005, Firmware: 0x0004, Sample: 0x000d, IAP: 0x000e
iul 22 23:51:34 localhost.localdomain kernel: Intel(R) Wireless WiFi driver for Linux
iul 22 23:51:34 localhost.localdomain kernel: iwlwifi 0000:02:00.0: Found debug destination: EXTERNAL_DRAM
iul 22 23:51:34 localhost.localdomain kernel: iwlwifi 0000:02:00.0: Found debug configuration: 0
iul 22 23:51:34 localhost.localdomain kernel: iwlwifi 0000:02:00.0: loaded firmware version 36.79ff3ccf.0 8000C-36.ucode op_mode iwlmvm
iul 22 23:51:34 localhost.localdomain kernel: Bluetooth: hci0: Minimum firmware build 1 week 10 2014
iul 22 23:51:34 localhost.localdomain kernel: Bluetooth: hci0: Found device firmware: intel/ibt-11-5.sfi
iul 22 23:51:34 localhost.localdomain kernel: iwlwifi 0000:02:00.0: Detected Intel(R) Dual Band Wireless AC 8260, REV=0x208
iul 22 23:51:34 localhost.localdomain kernel: iwlwifi 0000:02:00.0: Applying debug destination EXTERNAL_DRAM
iul 22 23:51:34 localhost.localdomain kernel: iwlwifi 0000:02:00.0: Allocated 0x00400000 bytes for firmware monitor.
iul 22 23:51:34 localhost.localdomain kernel: iwlwifi 0000:02:00.0: base HW address: b8:8a:60:c5:fc:e2
iul 22 23:51:34 localhost.localdomain kernel: ieee80211 phy0: Selected rate control algorithm 'iwl-mvm-rs'
iul 22 23:51:34 localhost.localdomain kernel: iwlwifi 0000:02:00.0 wlp2s0: renamed from wlan0
iul 22 23:51:34 localhost.localdomain kernel: Bluetooth: hci0: Waiting for firmware download to complete
iul 22 23:51:34 localhost.localdomain kernel: Bluetooth: hci0: Firmware loaded in 1748207 usecs
iul 22 23:51:34 localhost.localdomain kernel: Bluetooth: hci0: Firmware revision 0.0 build 10 week 41 2018
iul 22 23:51:39 localhost.localdomain service_harddrake[1082]: FIREWIRE_CONTROLLER took:  0:00:00
iul 22 23:51:44 localhost.localdomain network[1260]: Error for wireless request "Set Encode" (8B2A) :
iul 22 23:51:45 localhost.localdomain ifplugd(wlp2s0)[1579]: Using interface wlp2s0/B8:8A:60:C5:FC:E2 with driver <iwlwifi> (version: 5.6.14-desktop-2.mga7)
iul 22 23:52:38 localhost.localdomain kernel: IFWLOG: register target
meinsta
 
Posts: 10
Joined: Apr 29th, '20, 23:08

Re: Wifi networks not seen in Mageia 7

Postby jeevanism » Jul 23rd, '20, 17:42

As per the result you have provided
Code: Select all
1: phy0: Wireless LAN
        Soft blocked: yes


Your wireless driver is soft blocked. You can run below command to unblock all

Code: Select all
rfkill unblock all


for example in my machine - Bluetooh is soft blocked
Code: Select all
[root@jeevanism software]# rfkill list all
0: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: ideapad_wlan: Wireless LAN
        Soft blocked: no
        Hard blocked: no
2: ideapad_bluetooth: Bluetooth
        Soft blocked: yes
        Hard blocked: no
3: hci0: Bluetooth
        Soft blocked: yes
        Hard blocked: no


Now I unblocked all with below command
Code: Select all
[root@jeevanism software]# rfkill unblock all

now if you run the list all command, you can see the result.
Best wishes :)
Last edited by isadora on Jul 23rd, '20, 18:05, edited 1 time in total.
Reason: Quoting the former message is not appropriate
jeevanism
 
Posts: 69
Joined: Sep 1st, '12, 05:28

Re: Wifi networks not seen in Mageia 7

Postby meinsta » Jul 23rd, '20, 21:25

Great!
Thank you a lot! :)
Now it is working!
Gave a wonderful life!
meinsta
 
Posts: 10
Joined: Apr 29th, '20, 23:08


Return to Networking

Who is online

Users browsing this forum: No registered users and 1 guest