[SOLVED] TCP/UPD Access for LAN Games?

[SOLVED] TCP/UPD Access for LAN Games?

Postby bbondari » Sep 8th, '19, 23:54

Hi folks,

I'm new to Mageia, but not to Linux. Here's the basic problem: when trying to play old-school LAN games (such as Warcraft 3 through PlayOnLinux/WINE), I can neither host nor join local network games. This works just fine on Kubuntu (dual boot), but not on Mageia 7 Plasma. I have already completely disabled the Mageia firewall since that was my first instinct, but the problem remains. The games launch and run fine, but no network activity is allowed.

I'm sure I'm overlooking something obvious, but the firewall doesn't seem to be the problem. Perhaps it's related to NetworkManager? Any suggestions on where to start troubleshooting are most appreciated.

Thanks!
Last edited by bbondari on Sep 11th, '19, 00:27, edited 2 times in total.
bbondari
 
Posts: 4
Joined: Sep 8th, '19, 23:48

Re: TCP/UDP Access for LAN Games?

Postby bbondari » Sep 9th, '19, 15:48

And it's UDP, not UPD. Sorry about the typo in the title!
bbondari
 
Posts: 4
Joined: Sep 8th, '19, 23:48

Re: TCP/UPD Access for LAN Games?

Postby doktor5000 » Sep 9th, '19, 16:39

Would probably be helpful if you could post the output of
Code: Select all
iptables -L
as root here and also post the content of your /etc/hosts.

Regarding troubleshooting, easiest way would be to start the games without PlayOnLinux directly only using wine, and checking the actual output, then looking that up for the respective game in WineHQ App DB and/or their forums and their bugtracker https://bugs.winehq.org/ - often it's just a case that you need to install something via winetricks, e.g. DirectPlay or something similar.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 15022
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: TCP/UPD Access for LAN Games?

Postby bbondari » Sep 10th, '19, 01:59

Thanks, doktor5000.

My rules list is empty (it has the usual INPUT, FORWARD, and OUTPUT areas, but no rules listed). My /etc/hosts is simply:

Code: Select all
127.0.0.1    localhost
::1   localhost


I'm pretty confident it's not a problem with PlayOnLinux itself. Still scratching my head here....
bbondari
 
Posts: 4
Joined: Sep 8th, '19, 23:48

(SOLVED) Re: TCP/UPD Access for LAN Games?

Postby bbondari » Sep 10th, '19, 02:06

OK, I figured it out. It was a simple solution, and I feel like a total idiot that I didn't see it sooner.

I had used the PlayOnLinux Vault to restore Warcraft 3 on Mageia, and it was a different (older) patch version than the other computers in the house. THAT'S why I could neither see nor host any LAN games. I patched it to the latest version, and all is well. :oops:

Thanks for the help. I'm loving Mageia so far.
bbondari
 
Posts: 4
Joined: Sep 8th, '19, 23:48

Re: TCP/UPD Access for LAN Games?

Postby isadora » Sep 10th, '19, 08:54

Would you please mark this topic [SOLVED]?
You can do so by editing the title/subject of the first message in the topic.
Place [SOLVED] in front of subject/title.

Thanks ahead. :)
..........bird from paradise..........

Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.
—Antoine de Saint-Exupéry
User avatar
isadora
 
Posts: 2506
Joined: Mar 25th, '11, 16:03
Location: Amsterdam, the Netherlands


Return to Networking

Who is online

Users browsing this forum: No registered users and 1 guest

cron