D-link Nano Wireless adapter in Mageia 7

D-link Nano Wireless adapter in Mageia 7

Postby hviaene » Jan 11th, '19, 17:25

I could not get this device working in Mageia 6, because of a problem when compiling the driver.
This issue is solved in Mageia 6, but I got an even stranger problem now.
When I try to make a wifi connection with it in MCC- network manager, my wifi router is listed allright, I can enter the connection parameters, but then making the connection just fails.
Looking for info how to handle from the CLI, I found some info, so I did:
# ifconfig wlp0s29f7u4 up
That went OK
# iwlist wlp0s29f7u4 scan
Shows 25 possible connections, but my router is not listed in it (I am sure it shows up each and every time in MCC network manager)
So quite consistently I cannot make the connection with iwconfig, I get "Error for wireless request "Set Encode" (8B2A): Set failed on device wlp0s29f7u4 ; Invalid argument.
Any help????
hviaene
 
Posts: 65
Joined: Oct 11th, '13, 10:41

Re: D-link Nano Wireless adapter in Mageia 7

Postby hviaene » Jan 16th, '19, 10:27

Change: with the latest kernel from the updates installed, now the command
iwlist wlp0s29f7u4 scan
Lists my wifi router, at least the 24.GHz essid, not the 5GHz essid.
But that still does not get the connection working, I find no feedback anywhere, but maybe looking in the wrong place???
hviaene
 
Posts: 65
Joined: Oct 11th, '13, 10:41

Re: D-link Nano Wireless adapter in Mageia 7

Postby doktor5000 » Jan 16th, '19, 21:17

hviaene wrote:I find no feedback anywhere, but maybe looking in the wrong place???

Well, where are you looking?
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14658
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: D-link Nano Wireless adapter in Mageia 7

Postby hviaene » Jan 17th, '19, 10:06

At the CLI.
hviaene
 
Posts: 65
Joined: Oct 11th, '13, 10:41

Re: D-link Nano Wireless adapter in Mageia 7

Postby morgano » Jan 17th, '19, 17:23

If you open a terminal and as root issue journalctl -f there, then run the wifi commands in another terminal, does the journal tell something interesting?
Mandriva since 2006, then Mageia since 2011 at home & work. Thinkpad T40 T42p T43 T60 T61 T400. Aspire 7. Fileserver. Workstation using LVM, LUKS, VirtualBox, BOINC, Dropbox, CAD, urpmi-proxy, NextCloud...
morgano
 
Posts: 572
Joined: Jun 15th, '11, 17:51
Location: Kivik, Sweden

Re: D-link Nano Wireless adapter in Mageia 7

Postby hviaene » Jan 19th, '19, 13:18

on commands
Code: Select all
ifconfig wlp0s29f7u4 up

no feedback and nothing in journal
on command
Code: Select all
# iwlist wlp0s29f7u4 scan | grep via
                    ESSID:"via8ene9"

that's my 2.4Ghz . My 5Ghz from same router does not show up. Nothing in journal
on command
Code: Select all
# iwconfig wlp0s29f7u4 essid via8ene9 key s:<mykey>
Error for wireless request "Set Encode" (8B2A) :
    SET failed on device wlp0s29f7u4 ; Invalid argument.

and in the journal
Code: Select all
jan 19 12:10:00 mach6.hviaene.thuis kernel: wlp0s29f7u4: authenticate with 34:31:c4:80:a9:b6
jan 19 12:10:00 mach6.hviaene.thuis kernel: wlp0s29f7u4: send auth to 34:31:c4:80:a9:b6 (try 1/3)
jan 19 12:10:01 mach6.hviaene.thuis kernel: wlp0s29f7u4: send auth to 34:31:c4:80:a9:b6 (try 2/3)
jan 19 12:10:01 mach6.hviaene.thuis kernel: wlp0s29f7u4: send auth to 34:31:c4:80:a9:b6 (try 3/3)
jan 19 12:10:01 mach6.hviaene.thuis kernel: wlp0s29f7u4: authentication with 34:31:c4:80:a9:b6 timed out
j
Last edited by isadora on Jan 19th, '19, 13:48, edited 2 times in total.
Reason: Placed command-output in between [CODE]-tags for better readability ;)
hviaene
 
Posts: 65
Joined: Oct 11th, '13, 10:41


Return to Networking

Who is online

Users browsing this forum: No registered users and 1 guest

cron