D-link Nano Wireless adapter in Mageia 7

D-link Nano Wireless adapter in Mageia 7

Postby hviaene » Jan 11th, '19, 17:25

I could not get this device working in Mageia 6, because of a problem when compiling the driver.
This issue is solved in Mageia 6, but I got an even stranger problem now.
When I try to make a wifi connection with it in MCC- network manager, my wifi router is listed allright, I can enter the connection parameters, but then making the connection just fails.
Looking for info how to handle from the CLI, I found some info, so I did:
# ifconfig wlp0s29f7u4 up
That went OK
# iwlist wlp0s29f7u4 scan
Shows 25 possible connections, but my router is not listed in it (I am sure it shows up each and every time in MCC network manager)
So quite consistently I cannot make the connection with iwconfig, I get "Error for wireless request "Set Encode" (8B2A): Set failed on device wlp0s29f7u4 ; Invalid argument.
Any help????
hviaene
 
Posts: 63
Joined: Oct 11th, '13, 10:41

Re: D-link Nano Wireless adapter in Mageia 7

Postby hviaene » Jan 16th, '19, 10:27

Change: with the latest kernel from the updates installed, now the command
iwlist wlp0s29f7u4 scan
Lists my wifi router, at least the 24.GHz essid, not the 5GHz essid.
But that still does not get the connection working, I find no feedback anywhere, but maybe looking in the wrong place???
hviaene
 
Posts: 63
Joined: Oct 11th, '13, 10:41

Re: D-link Nano Wireless adapter in Mageia 7

Postby doktor5000 » Jan 16th, '19, 21:17

hviaene wrote:I find no feedback anywhere, but maybe looking in the wrong place???

Well, where are you looking?
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14571
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany


Return to Networking

Who is online

Users browsing this forum: No registered users and 1 guest

cron