xscanimage segmantation fault

xscanimage segmantation fault

Postby hviaene » Feb 17th, '21, 11:44

Mageia 7.1 x86-64 fully updated.
In the past I have used xscanimage every now and then, usually I prefer xsane. But no problems since my first Mageia 2.
Up to recently I had one scanner Epson 2400 Photo scanner aka GT9300. But my printer was gone south and I replaced it with an HP Envy 6022, which is an all-in-one.
xsane works perfectly with both when I select one or the other scanner when starting it. But xscanimage asks which one to use, and which of the two I take doesn't matter, xscanimage bumps out; segmentation fault - core dumped.
I did an strace on it, and at the end I see:
Code: Select all
sendto(141, "<14>Feb 17 09:58:11 xscanimage: "..., 97, MSG_NOSIGNAL, NULL, 0) = 97
sendto(141, "<14>Feb 17 09:58:11 xscanimage: "..., 76, MSG_NOSIGNAL, NULL, 0) = 76
sendto(141, "<14>Feb 17 09:58:11 xscanimage: "..., 85, MSG_NOSIGNAL, NULL, 0) = 85
sendto(141, "<14>Feb 17 09:58:11 xscanimage: "..., 88, MSG_NOSIGNAL, NULL, 0) = 88   - In fact a whole wagonload of those
futex(0x7f97efde6688, FUTEX_WAKE_PRIVATE, 2147483647) = 0
futex(0x7f97efde6688, FUTEX_WAKE_PRIVATE, 2147483647) = 0
access("/usr/share/fonts/TTF/dejavu/DejaVuSans.ttf", R_OK) = 0
--- SIGSEGV {si_signo=SIGSEGV, si_code=SEGV_MAPERR, si_addr=NULL} ---
+++ killed by SIGSEGV (core dumped) +++
Last edited by isadora on Feb 17th, '21, 13:11, edited 1 time in total.
Reason: Topic moved into appropriate sub-forum. And please place command-output between [CODE]-tags, for better readability.
hviaene
 
Posts: 116
Joined: Oct 11th, '13, 10:41

Re: xscanimage segmantation fault

Postby morgano » Feb 17th, '21, 15:10

Long since i used xscanimage.
Tried it now and I confirm yes it segfaults: If i have no scanner it exits cleanly saying it did not find one, and if i have my scanner connected it segfaults.
xsane works as usual :)
Mandriva since 2006, then Mageia since 2011 at home & work. Thinkpad T43 & T400, Dell M4400, Acer Aspire 7. Workstation using LVM, LUKS, VirtualBox, BOINC
morgano
 
Posts: 796
Joined: Jun 15th, '11, 17:51
Location: Kivik, Sweden

Re: xscanimage segmantation fault

Postby morgano » Feb 17th, '21, 15:38

I see there is a stalled bug

Is there a configuration file that can be reset?
Mandriva since 2006, then Mageia since 2011 at home & work. Thinkpad T43 & T400, Dell M4400, Acer Aspire 7. Workstation using LVM, LUKS, VirtualBox, BOINC
morgano
 
Posts: 796
Joined: Jun 15th, '11, 17:51
Location: Kivik, Sweden

Re: xscanimage segmantation fault

Postby doktor5000 » Feb 17th, '21, 17:53

morgano wrote:I see there is a stalled bug


That is only about scanning in 48bit color mode, this is not even similar to xscanimage segfaulting directly during startup.

@hviaene: Can you check what you have in /etc/sane.d/dll.conf - is there an entry "hpaio" (for an HP scanner, not sure what backend your Epson scanner uses) ?
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16741
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: xscanimage segmantation fault

Postby hviaene » Feb 17th, '21, 18:23

There is an entry hpaio, and there are entries for epson as well. When epson is shown to be selected (applies also to xsane) it is shown as usbxxxxxxxx
hviaene
 
Posts: 116
Joined: Oct 11th, '13, 10:41

Re: xscanimage segmantation fault

Postby morgano » Feb 17th, '21, 18:48

Mine is an epson perfection 1660 photo, from last millenium.
Experiment:
If /etc/sane.d/dll.conf does not contain the line
epson2
then xscanimage replies i do not find the scanner.
If the line is there it segfaults.
My /etc/sane.d/dll.d folder is empty.
Mandriva since 2006, then Mageia since 2011 at home & work. Thinkpad T43 & T400, Dell M4400, Acer Aspire 7. Workstation using LVM, LUKS, VirtualBox, BOINC
morgano
 
Posts: 796
Joined: Jun 15th, '11, 17:51
Location: Kivik, Sweden

Re: xscanimage segmantation fault

Postby hviaene » Feb 21st, '21, 12:33

When I start the PC with the HP switched off, thus only the Epson scanner visible, xscanimage immediately bombs out.

Is it worthwhile logging a bug for this issue????
hviaene
 
Posts: 116
Joined: Oct 11th, '13, 10:41

Re: xscanimage segmantation fault

Postby morgano » Feb 22nd, '21, 12:50

hviaene wrote:Is it worthwhile logging a bug for this issue????

Yes please, and post bug link here.
Mandriva since 2006, then Mageia since 2011 at home & work. Thinkpad T43 & T400, Dell M4400, Acer Aspire 7. Workstation using LVM, LUKS, VirtualBox, BOINC
morgano
 
Posts: 796
Joined: Jun 15th, '11, 17:51
Location: Kivik, Sweden

Re: xscanimage segmantation fault

Postby hviaene » Feb 22nd, '21, 14:37

hviaene
 
Posts: 116
Joined: Oct 11th, '13, 10:41


Return to Printers and Scanners

Who is online

Users browsing this forum: No registered users and 1 guest