Page 1 of 1

Scanner keeps disappearing...:-(

PostPosted: Sep 4th, '20, 14:23
by lloyd
I have an old Samsung SCX-4200 printer/scanner. I don't use it as a printer because a toner cartridge costs more than what I paid for the whole printer...typical.
So, scanner it is.....

It is connected by a USB cable. It says the printer/scanner is a Xerox Orion engine, but is now supported by HP for the driver....hmmmm

Now for the actual problem:

In order to scan anything, I have to catch the scanner at exactly the right soon as it comes to the READY state. As soon as the scanner goes into power saving mode, it just "disappears" and scanning programs can't find it. This behavior has happened in the last few versions of Mageia. Maybe it is not a Mageia-specific problem I usually use Xsane, but they all exhibit the same behavior. I'm assuming there is nothing to wake it up from an energy-saving state.Why does the scanner just vanish? Really, the only way to fix it is to turn the scanner off and on and catch it at the brief READY moment. I would really like it to be persistent. I'm going to try the possibility that the Windows driver may allow me to turn off the energy-saving state.

Any help would be greatly appreciated!
Thank you!

A bit more on this....I think part of the problem is the power-saving mode. I d/l the manual and turned that off. Amazing what you can find in the manuals....but that didn't quite fix it. At least it doesn't time out now.

So, the big test....the scanner is still in the ready state (the green light is on). So, I tried rebooting (I left the scanner on) and tried running Xsane again. It came up with a message that says "no devices available." So it's not quite right yet...:-(