Page 1 of 1

[SOLVED] Epson V600 Scanner does not work with Mageia 7

PostPosted: Feb 11th, '20, 16:53
by banjo
As others have posted, my Epson Scanner would not work with the new Mageia 7 out of the box. I was able to get it working, so I am posting this in case others have the same problem and can get theirs working using this information.

According to the Mageia Wiki page it is necessary to fix the Epson scanner problem before ever searching for a scanner or the fix will not work.

It is important to apply this installation procedure during the initial customization process after system-install or, at least, before Linux has searched for a scanner device. Otherwise, the scanner will not correctly recognized - in that case, repeating the steps described above will not help. This approach being rather empirical, I do not know the reason why the only way to get things right again is a complete re-install.

I have found that is not the case when I follow the procedures below. I did not even have to reboot the computer, much less reinstall the OS.

My scanner is an Epson Perfection V600 Photo. Model: J252A

Here is a summary of the basic procedure.

    1. Download the Epson proprietary SANE backend.
    2. Uninstall some conflicting SANE packages that were installed by default.
    3. Install the Epson backend.

1. Download the Epson proprietary SANE backend.

Look up your scanner at the SANE support page to find the backend that supports the scanner. The page is here: ... ernal.html

According to the page the Epson Perfection V600 Photo uses the epkowa backend.

Go to the Epson download page to get the drivers. ... archModule

Search for the product, “v600” and the “Linux” OS. That should take you to a page where you can download the driver

Download the all-in-one package, mine was iscan-gt-x820-bundle-2.30.4.x64.rpm.tar.gz. Put it somewhere that it can be found for manual installation. Notice that all of the required packages are now included in a single download. In the past you had to download three separate packages.

2. Uninstall some SANE packages installed by default.

The Mageia 7 Xsane program installs some default packages that do not work with the Epson scanners. They also conflict with the Epson scanners. They must be uninstalled before installing the Epson backend. These are


Change to root and issue the following commands.
Code: Select all
# urpme sane-backends-iscan-1.0.27-4.mga7
# urpme saned-1.0.27-4.mga7

On one of my systems the saned-1.0.27-4.mga7 was not installed by default, so uninstalling it was not necessary.

It is also necessary to move the file /usr/sbin/iscan-registry to get rid of it. If it is there, the installation of the Epson core backend will fail. On one of my systems uninstalling the sane backend got rid of it, but on the other one the file was left.

As root, issue the following commands.

Code: Select all
#cd /usr/sbin
#mv iscan-registry iscan-registry.orig

Suggestion: Don’t just delete the file, rename it so that it can be restored if necessary.

3. Install the Epson backend.

Extract the zip file iscan-gt-x820-bundle-2.30.4.x64.rpm.tar.gz into a folder, for example, /home/<username>/EpsonScanner/v600driver. It doesn't matter where you put it.

That will provide the tree of files:
├── Image\ Scan\ for\ Linux\ Manual.pdf
├── iscan-gt-x820-bundle-2.30.4.x64.rpm
│   ├── core
│   │   └── iscan-2.30.4-2.x86_64.rpm
│   ├── data
│   │   └── iscan-data-1.39.1-2.noarch.rpm
│   ├──
│   ├── plugins
│   │   └── iscan-plugin-gt-x820-2.2.1-1.x86_64.rpm
│   └── README.rst
└── iscan-gt-x820-bundle-2.30.4.x64.rpm.tar.gz

Do not use the installation script, I tried it and it went bonkers and did crazy things to the system. Install the three packages manually.

The order of installation is important. It is described in this document:

The order of installation is


Issue the following commands as root to do the installation. Go to the location where the drivers were extracted
and install each module.

Code: Select all
#cd /home/<username>/EpsonScanner/v600driver/iscan-gt-x820-bundle-2.30.4.x64.rpm
#urpmi data/iscan-data-1.39.1-2.noarch.rpm
#urpmi core/iscan-2.30.4-2.x86_64.rpm
#urpmi plugins/iscan-plugin-gt-x820-2.2.1-1.x86_64.rpm

Following the instructions at page ... g_scanner/

I edited the file /etc/sane.d/dll.conf and added the line

Code: Select all

to it, for example,

Code: Select all

I do not know if that is strictly necessary or not. I did it anyway to be safe.

I then ran scanimage -L and it found the scanner.

I then ran Xsane and it found the scanner.

Confirm that the plugin has been installed.

Code: Select all
$ which iscan

Useful commands to remember:

Code: Select all
lsusb – to get the product hex numbers from the scanner.
scanimage -L
sane-find-scanner – to see if the scanner is visible

Using the scanner

Turn on the scanner, bring up a terminal and issue the iscan commad. The Image Scan GUI should appear. Similarly, xsane can be used to control the scanner.

The iscan tool can be installed as a plugin for the GIMP according to the web page:

Close down the GIMP and create a link to iscan in the plug-ins directory of the GIMP.

Code: Select all
$ cd ~/.config/GIMP/2.10/plug-ins
$ ln -s /usr/bin/iscan iscan

Run the GIMP

Turn the scanner on and use File=>Create=>Scanning (iscan)… That will open the iscan GUI and allow you to work the scanner. The plugin will create the image directly in the GIMP.

I hope this information will help anyone who is struggling with this issue.

Re: [SOLVED] Epson V600 Scanner does not work with Mageia 7

PostPosted: Sep 4th, '20, 12:38
by kajosim
Some of the problems mentioned in the Mageia Wiki page may have been solved.
I have an Epson 4870 aka GT-X700 and I had in previous Mandrake / Mandriva / Mageia to fix minor issues.
I do recognize some of the issues mentioned by banjo above.

But yesterday Mageia 7 gave me no issues at all.
I did the following - the order may be important !

1: in MCC > Hardware > set up scanner. This installs several packages
2: in MCC Install software : search for xsane . It will show that the xsane-gimp plugin is not installed, so install it. Do not install other packages!
Now running GIMP I can scan using sane.
3: download the Epson iscan.xx.tar.gz and install as banjo explains in section 3 above.
I did not install any plugins, only data/iscan-data-xx and core/iscan-xx

That was it. Now using GIMP I can choose to either use sane or Epson iscan . In most cases iscan is best but it is nice to have sane as an alternative.
In GIMP it is File > Create > iscan/sane that will give the choise for scanning.