[SOLVED] CUPS : "Widows Printer via Samba" option is missing

[SOLVED] CUPS : "Widows Printer via Samba" option is missing

Postby Can80 » Sep 18th, '18, 22:49

Hello everybody.

I have set up a Mageia 6 (X86_64) system on my computer at work and it is running like a charm!
I am however running into an issue that keeps me from connecting to the printing service on our network.
I know that I have to do it via Samba. The process should be simple and straight forward.

But strangely, whether I go through the Control Center or CUPS (http://localhost:631/admin), the option to add "Windows Printer via Samba" is missing and I haven't managed to make it appear so far.
I have tried some of the solutions that were proposed for other systems, which consist mostly in installing packages like python-smbc and other smb-related packages, but no luck so far.

I'm guessing that a link has to be made somewhere between CUPS and smbspool (or smbprint). But I truly don't know.

Would somebody have an idea?

I am not providing any detailed information on my system now, because I have no clue what information would be useful.

Thank you for your time and your help!
Missing SMB option.png
Missing SMB option.png (54.11 KiB) Viewed 162 times
Last edited by Can80 on Sep 19th, '18, 21:13, edited 1 time in total.
Posts: 7
Joined: Sep 18th, '18, 21:19

Re: CUPS : the "Widows Printer via Samba" option is missing

Postby Can80 » Sep 19th, '18, 18:58

Hello again!

After lots of searching and reading everywhere, I have found and solved my problem.
It turns our that the option was missing in the /usr/lib/cups/backend/ directory. So in order to fix that, I created the missing link and restarted CUPS:
Code: Select all
# ln -s /usr/bin/smbspool /usr/lib/cups/backend/smb
# service cups restart

And Voilà!
So all the extra packages I installed were probably unnecessary.

Sorry for the bother.
Still, I hope this can be useful for anyone who happens to run into the same issue.

Best Regards! :)
SMB option available.png
SMB option available.png (64.99 KiB) Viewed 150 times
Posts: 7
Joined: Sep 18th, '18, 21:19

Re: CUPS : the "Widows Printer via Samba" option is missing

Postby isadora » Sep 19th, '18, 19:31

Would you mind, marking this topic [SOLVED]?
You can do so by editing the title/subject of the first message in the topic.
Place [SOLVED] in front of subject/title.

Thanks ahead. :)
..........bird from paradise..........

Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.
—Antoine de Saint-Exupéry
User avatar
Posts: 2435
Joined: Mar 25th, '11, 16:03
Location: Amsterdam, the Netherlands

Return to Printers and Scanners

Who is online

Users browsing this forum: No registered users and 1 guest