No network scanner in Mageia 7

No network scanner in Mageia 7

Postby mark9117 » Dec 17th, '19, 03:29

Just upgraded my file server to Mageia 7. It seemed to go pretty well, but even with good backups, I'm not able to get some stuff back. For example, my flatbed scanner is no longer working over the network. The scanner (details below) is connected to the server via USB and has been working just fine for years. It still works on the server locally, but I can no longer get my Mageia 7 desktop to connect to it. Again, it all worked just fine prior to the upgrade. I don't see this as network trouble. I may be wrong.

Here are some details.

Linux shuttle 5.4.2-desktop-1.mga7 #1 SMP Thu Dec 5 17:40:00 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

(from "scanimage -L" on the server) device `genesys:libusb:002:002' is a Canon LiDE 110 flatbed scanner

scanimage (sane-backends) 1.0.27; backend version 1.0.28

Scanner works locally on server (192.168.1.105), but does not work from a desktop on the LAN (192.168.1.106). I removed (x)sane from the server to test without it. It made no difference - the desktop still can't find the scanner.

I am unable to connect to port 6566 on the server via telnet. Connection closes immediately:

Code: Select all
# telnet shuttle 6566
Trying 192.168.1.105...
Connected to shuttle.
Escape character is '^]'.
Connection closed by foreign host.


scanimage -L on the desktop fails to see the scanner

saned.socket is running:

Code: Select all
# systemctl status saned.socket
● saned.socket - saned incoming socket
Loaded: loaded (/etc/systemd/system/saned.socket; enabled; vendor preset: disabled)
Active: active (listening) since Sun 2019-12-15 20:41:33 MST; 13h ago
Listen: [::]:6566 (Stream)
Accepted: 36; Connected: 0;
Memory: 128.0K
CGroup: /system.slice/saned.socket

Dec 15 20:41:33 shuttle systemd[1]: Listening on saned incoming socket.


saned.socket shows open and listening per other tools as well:

Code: Select all
nmap -sV shuttle -p 6566
Starting Nmap 7.70 ( https://nmap.org ) at 2019-12-16 10:34 MST
Nmap scan report for shuttle (192.168.1.105)
Host is up (0.00015s latency).

PORT STATE SERVICE VERSION
6566/tcp open tcpwrapped


# netstat -l |grep sane-port
tcp6 0 0 [::]:sane-port [::]:*

my user is in the server's "scanner" group
saned is in "lp" group
Firewalls are down

/etc/saned/net.conf:

Code: Select all
## saned hosts
::1
localhost
192.168.1.106
192.168.1.105


/etc/hosts.allow is set for ALL:AL

The only thing I notice that seems questionable is an undefined symbol that shows up in the journalctl readout from the server when I try to connect to the scanner from the desktop:

Code: Select all
Dec 16 15:49:00 shuttle saned[24912]: /usr/sbin/saned: symbol lookup error: /usr/sbin/saned: undefined symbol: sanei_w_init
Dec 16 15:49:00 shuttle systemd[1]: saned@71-192.168.1.105:6566-192.168.1.106:36174.service: Main process exited, code=exited, status=127/n/a
Dec 16 15:49:00 shuttle systemd[1]: saned@71-192.168.1.105:6566-192.168.1.106:36174.service: Failed with result 'exit-code'.


I can't think of anything else to check. Does anybody here have any suggestions?

Thanks for the time and attention.

Mark
Last edited by isadora on Dec 17th, '19, 09:17, edited 1 time in total.
Reason: Topic moved into appropriate sub-forum.
Let's just reboot everything all the time.
User avatar
mark9117
 
Posts: 392
Joined: Sep 12th, '11, 20:32
Location: Eastern New Mexico -- Not Hell, but you can see it from here.

Re: No network scanner in Mageia 7

Postby mark9117 » Dec 21st, '19, 21:48

*bump*

Does anybody see anything this just *might* be wrong?
Let's just reboot everything all the time.
User avatar
mark9117
 
Posts: 392
Joined: Sep 12th, '11, 20:32
Location: Eastern New Mexico -- Not Hell, but you can see it from here.

Re: No network scanner in Mageia 7

Postby KnightMB » Jun 30th, '20, 05:49

mark9117 wrote:*bump*

Does anybody see anything this just *might* be wrong?

I just ran into this, seems the saned service does not install properly. Tried it on the 32bit and 64bit versions, seems to be missing some files for the saned service to work properly. :?

Edit: the missing file is saned.service
From https://wiki.mageia.org/en/Saned
User avatar
KnightMB
 
Posts: 69
Joined: Nov 21st, '12, 21:27

Re: No network scanner in Mageia 7

Postby KnightMB » Jun 30th, '20, 06:14

Here was my solution for Mageia 7 (32 bit and 64 bit)
After you install Saned, run these commands on the server console (as root)
Code: Select all
Start It Now
systemctl start saned.socket

Make it start automatically on startup with the following command:
systemctl enable saned.socket

Check if saned.socket is running with the command below:
systemctl status saned.socket
User avatar
KnightMB
 
Posts: 69
Joined: Nov 21st, '12, 21:27

Re: No network scanner in Mageia 7

Postby doktor5000 » Jun 30th, '20, 16:27

KnightMB wrote:Edit: the missing file is saned.service
From https://wiki.mageia.org/en/Saned


No, it's not missing. See /usr/lib/systemd/system/saned@.service

Also there should be no need to enable saned.socket or start it, because this is supposed to socket-activate.
Meaning on incoming connections it's automatically started. This is also happening in your initial connection in your OP - saned starts as saned@71-192.168.1.105:6566-192.168.1.106:36174.service
but it doesn't run successfully due to the undefined symbol. That is a packaging error and should be reported as a bug.

FWIW this was already explained to you in the crosspost https://www.linuxquestions.org/question ... 175666058/
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 15830
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: No network scanner in Mageia 7

Postby KnightMB » Jun 30th, '20, 18:54

I can report it, you are right, seems all the files are there. The documentation of how to start it probably should be updated since the package installation isn't enabling the socket for some reason. Would it make more sense to update the wiki or is the package installation suppose to automatically enable the socket?
User avatar
KnightMB
 
Posts: 69
Joined: Nov 21st, '12, 21:27

Re: No network scanner in Mageia 7

Postby doktor5000 » Jun 30th, '20, 21:39

It is supposed to be socket-activated, meaning the socket should start with an incoming connection.

[doktor5000@Mageia7]─[20:54:35]─[~] systemctl status saned.socket
● saned.socket - saned incoming socket
Loaded: loaded (/usr/lib/systemd/system/saned.socket; disabled; vendor preset: disabled)
Active: inactive (dead)
Listen: [::]:6566 (Stream)
Accepted: 0; Connected: 0;


This is also explained in detail in the saned man page in the sections below "SYSTEMD CONFIGURATION"
I don't have a (network) scanner, so can't really test this out further.

From what I can tell, our saned@.service is wrong, it should have StandardInput=socket which is the important part for socket activation. Ours has StandardInput=null
You could try to edit it via
Code: Select all
systemctl edit saned@.service
and replace StandardInput=null with StandardInput=socket
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 15830
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany


Return to Printers and Scanners

Who is online

Users browsing this forum: No registered users and 1 guest

cron