Install scanner Canoscan LIDE 120

Re: Install scanner Canoscan LIDE 120

Postby doktor5000 » Apr 13th, '18, 18:29

cldjean wrote:When I run as root, Xsane recognizes the scanner but doesn't work properly. Booting preview wizard takes a very long time and when preview is done, the image is dark.

"image is dark" means the image is OK and just too dark, or is it completely black?
Then this sounds like https://bugs.mageia.org/show_bug.cgi?id=21244 which seems to be a problem with an USB 3 port, and the same scanner works with an USB 2 port.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14397
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Install scanner Canoscan LIDE 120

Postby cldjean » Apr 15th, '18, 08:48

Yes, the image is completly dark.

About the USB port what do you propose ?

Regards
cldjean
 
Posts: 21
Joined: Oct 3rd, '17, 05:46

Re: Install scanner Canoscan LIDE 120

Postby morgano » Apr 15th, '18, 12:34

cldjean wrote: About the USB port what do you propose ? Regards


Do you have a non-USB3 port on your computer?

https://bugs.mageia.org/show_bug.cgi?id=15413#c15
Mandriva since 2006, then Mageia since 2011 at home & work. Thinkpad T40 T42p T43 T60 T61 T400. Aspire 7. Fileserver. Workstation using LVM, LUKS, VirtualBox, BOINC, Dropbox, CAD, urpmi-proxy, NextCloud...
morgano
 
Posts: 519
Joined: Jun 15th, '11, 17:51
Location: Kivik, Sweden

Re: Install scanner Canoscan LIDE 120

Postby cldjean » Apr 15th, '18, 12:47

How can I see it ?
cldjean
 
Posts: 21
Joined: Oct 3rd, '17, 05:46

Re: Install scanner Canoscan LIDE 120

Postby doktor5000 » Apr 15th, '18, 17:48

That is also mentioned in the linked bug report(s). lsusb -t should also show it.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 14397
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Install scanner Canoscan LIDE 120

Postby cldjean » Apr 16th, '18, 08:48

Here is the results of lsusb -t command

Code: Select all
[jeanc@localhost ~]$ lsusb -t
/:  Bus 07.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
    |__ Port 2: Dev 2, If 0, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 2: Dev 2, If 1, Class=Human Interface Device, Driver=usbhid, 12M
    |__ Port 2: Dev 2, If 2, Class=Human Interface Device, Driver=usbhid, 12M
/:  Bus 06.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/:  Bus 05.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
    |__ Port 1: Dev 2, If 0, Class=Wireless, Driver=btusb, 12M
    |__ Port 1: Dev 2, If 1, Class=Wireless, Driver=btusb, 12M
    |__ Port 1: Dev 2, If 2, Class=Vendor Specific Class, Driver=, 12M
    |__ Port 1: Dev 2, If 3, Class=Application Specific Interface, Driver=, 12M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/6p, 480M
    |__ Port 1: Dev 2, If 0, Class=Vendor Specific Class, Driver=, 480M
    |__ Port 5: Dev 3, If 0, Class=Mass Storage, Driver=usb-storage, 480M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/4p, 480M


It seems I only have non-USB3 port.
cldjean
 
Posts: 21
Joined: Oct 3rd, '17, 05:46

Re: Install scanner Canoscan LIDE 120

Postby morgano » Apr 16th, '18, 09:23

Hm strange. 12M is actually USB 1.1 speed. https://en.wikipedia.org/wiki/USB
My USB2 hubs get listed at 480M and my USB3 at 5000M
what do lsusb without "-t" tell?
Mandriva since 2006, then Mageia since 2011 at home & work. Thinkpad T40 T42p T43 T60 T61 T400. Aspire 7. Fileserver. Workstation using LVM, LUKS, VirtualBox, BOINC, Dropbox, CAD, urpmi-proxy, NextCloud...
morgano
 
Posts: 519
Joined: Jun 15th, '11, 17:51
Location: Kivik, Sweden

Re: Install scanner Canoscan LIDE 120

Postby cldjean » Apr 16th, '18, 11:26

I have a HP Compaq 6510b, it's quite an old machine.

Here is the answer
Code: Select all
[jeanc@localhost ~]$ lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 002: ID 279e:024e 
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 03f0:171d Hewlett-Packard Bluetooth 2.0 Interface [Broadcom BCM2045]
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
cldjean
 
Posts: 21
Joined: Oct 3rd, '17, 05:46

Re: Install scanner Canoscan LIDE 120

Postby morgano » Apr 16th, '18, 11:46

Shooting in the dark as i do not know these matters...
But USB1.1 is probably slow to use if it even works so first make sure it is on a USB2 port...
I dont know off hand how to tell what port the scanner is on, but "lsusb -v" may give a lead, and also watch system log while you plug it in:
I.e in konsole log in as root and issue "journalctl -f", then plug in your scanner and watch it being detected as USB device.
Mandriva since 2006, then Mageia since 2011 at home & work. Thinkpad T40 T42p T43 T60 T61 T400. Aspire 7. Fileserver. Workstation using LVM, LUKS, VirtualBox, BOINC, Dropbox, CAD, urpmi-proxy, NextCloud...
morgano
 
Posts: 519
Joined: Jun 15th, '11, 17:51
Location: Kivik, Sweden

Previous

Return to Printers and Scanners

Who is online

Users browsing this forum: No registered users and 1 guest

cron