Page 1 of 1

[solved]bumblebee no device found

PostPosted: Jun 7th, '21, 14:08
by pmithrandir

I got a not so new laptop recently.
Inside, there is an Nvidia 920M hybrid card.

I would like to enable it, and I'm trying bumlblebee for that purpose. (I don't udnerstand quite well how to use mageia prime... seems very manual process to me)

When I run optirun, I get the following message :
Code: Select all
[root@localhost ~]# optirun glxspheres 64
[ 1324.476304] [ERROR]Cannot access secondary GPU - error: Could not load GPU driver

[ 1324.476372] [ERROR]Aborting because fallback start is disabled.

Do you know how I can resolve it ?
I checked and the nvidia-current kerneldriver is selected in the xOrg nvidia file.
Also, I defined manually the PCI bus, but with no success so far.

Any other idea ?

Best regards,

Re: bumblebee no device found

PostPosted: Jun 7th, '21, 14:44
by sturmvogel
Did you use these instructions for setup?

And I'm not sure if this is the source of this error message, but according to the instructions it should be this command without blank (you used 'glxspheres 64'):
Code: Select all
$ optirun glxspheres64

In our wiki there is also a really short instruction for Mageia-prime:

Re: bumblebee no device found

PostPosted: Jun 7th, '21, 14:58
by pmithrandir

I somehow followed the wiki.
I first went to the rpm manager, to add bumble bee in graphical mode.

Then, I tried with the command line and it was said everything was installed.

All command in "usage" section fail.

Regarding mageia prime, it seems that I'll have to keep switching back and forth between both system manually... looks awful to me compared to optirun way that I can simply inject in my shortcut.
Maybe I didn't understand well the principle behind, because it looks so much like a regression that I must be wrong.

Re: bumblebee no device found

PostPosted: Jun 7th, '21, 16:51
by doktor5000
pmithrandir wrote:All command in "usage" section fail.

That should give you a hint that maybe the setup is not yet complete or incorrect.

Also if you have nvidia-current as driver already in your xorg.conf, then that's what X starts with - then there's no need to run optirun at all, if I understood correctly what you described.

Re: bumblebee no device found

PostPosted: Jun 7th, '21, 21:17
by pmithrandir
Hi Doktor.

I have only 3 command to execute... not so much that I can do when they all seems to be ok.

My current card is intel in the main x configuration.
By nvidia current, was refering to the /etc/bumblebee/xorg.conf.nvidia file.

Sorry for the confusion.

Re: bumblebee no device found

PostPosted: Jun 8th, '21, 12:16
by pmithrandir

I started a fresh install on M8(the one before was a M6 updated twice plus moved from a computer to another...)

It's working now.


Re: [solved]bumblebee no device found

PostPosted: Jun 8th, '21, 23:26
by morgano
Great then!
Thanks for the update :)