Page 1 of 1

[SOLVED] Libx26x video compressor not supported

PostPosted: Nov 30th, '19, 20:37
by Linares
· "Libx264 video compressor not supported" when I want to process my project in generic MP4.

· "Libx265 video compressor not supported" when I want to process my project in MP4 in 4K.

Image

Trying to solve these errors, I performed the following actions, but they did not work:

In Konsole I executed drakrpm-edit-media. There I marked "Tainted Release" as Enabled. In Install applications, I selected "All",
making sure I was not only in "Packages with graphical interface". In the search engine I wrote x264 and 5 packages appeared. I marked them all and installed. But as I said, this has not worked.

How can I finish my projects in an MP4 file?

Re: Libx26x video compressor not supported

PostPosted: Dec 1st, '19, 15:04
by doktor5000
For x264 you need to install the compressor that is named exactly that - x264, which is from tainted release repo: https://madb.mageia.org/package/show/ap ... /name/x264
For x265, it's the same: https://madb.mageia.org/package/show/ap ... /name/x265

Re: Libx26x video compressor not supported

PostPosted: Dec 1st, '19, 22:30
by Linares
Hi Doktor5000.

I have already installed the two things that you indicated to me, but in Kdenlive the same error persists.

x264 y x265.gif
x264 y x265.gif (54.72 KiB) Viewed 171 times

Re: Libx26x video compressor not supported

PostPosted: Dec 2nd, '19, 19:47
by doktor5000
Can you check what you get when you run settings > config wizard to force a re-check for codecs ?
What you can also try, from the kdenlive manual: Settings -> Configure Kdenlive and check the Bypass codec verification option:
https://userbase.kde.org/Kdenlive/Manua ... n_Problems

Seems to reproduce this, one would actually need to load a video into kdenlive, otherwise the transcode dialog won't open. Will try again once I've got a free video available in my VM.

Re: Libx26x video compressor not supported

PostPosted: Dec 4th, '19, 18:36
by Linares
Thanks, doktor5000.

After many laps, inquiries and investigations, I have managed to enable my Kdenlive to enable the x264 and x265 compressors.

It seems that, in my system, some repositories were missing, such as Tainted Updates, Tainted 32bit Release and Tainted 32bit Updates.

After activating all those repositories in the control center, I uninstalled Kdenlive with urmpe kdenlive. I updated the system with urpmi --auto-update and reinstalled Kdenlive with urpmi kdenlive. When I restarted, my computer was blocked, apparently due to some hanging process, but now I open Kdenlive and those two video compressors in MP4 are not crossed out.

I reiterate my thanks for your willingness to help.

Re: Libx26x video compressor not supported

PostPosted: Dec 4th, '19, 18:37
by isadora
Would you please mark this topic [SOLVED]?
You can do so by editing the title/subject of the first message in the topic.
Place [SOLVED] in front of subject/title.

Thanks ahead. :)