[SOLVED] Update broke Nvidia driver

[SOLVED] Update broke Nvidia driver

Postby marydou » Feb 17th, '19, 21:32

I installed the recent updates in M6, and among them were Nvidia and virtualbox packages. I didn't reboot immediately, and later I saw screen was into text mode and couldn't type anything, as if the cursor was blinking constantly. I rebooted and got into a text screen that advised to "login as root and run drakx11 to configure display".

The installed driver was dkms-nvidia-current-410.78-1.1.mga6.nonfree. After trying to find a solution searching the board, I used

urpme dkms-nvidia-current
urpmi dkms-nvidia-current

which installed dkms-nvidia-current-390.87-1.mga.nonfree, but upon rebooting I end up with the same text screen.

What can I do to bring it back?
Last edited by doktor5000 on Feb 18th, '19, 19:39, edited 1 time in total.
Reason: marked as solved
Posts: 6
Joined: Feb 17th, '19, 21:19

Re: Update broke Nvidia driver

Postby marydou » Feb 18th, '19, 08:23

OK, I somehow solved the problem after hours of headache.

After gathering bits and pieces from various places, I went into runlevel 3 by running

Code: Select all
systemctl set-default multi-user.target

and started drakx11. I selected another nvidia option instead of the "GeForce 420 series" and installed it. (in drakx you can't select an option using enter key, but you highlight your option and press tab to go to OK and press the enter key, which is different to what I was used to expect).

then back to runlevel 5 by running

Code: Select all
systemctl set-default graphical.target

Instead of driver version 410.78 I ended up with 390-87.

When I booted into DE, I used MCC to select "GeForce 420 series" and see if I end up with the latest driver. Instead, I ended up with the login screen going into an endless loop every time I entered the user password. After a few more hours of searching, I finally entered root as user and entered the DE. Suspecting this is odd, I went into user's home folder (not root's home folder!) and entered

Code: Select all
ls -lah

which revealed that .Xauthority was now owned by root. This was solved by

Code: Select all
chown user:user .Xauthority

I hope that this will save someone from a similar situation.

I suspect that somehow the update problems were caused by kernel 4.18, as (maybe unrelated?) virtualbox was also broken because of this, as currently there is not an appropriate virtualbox driver for a kernel version higher than 4.14. The dkms-nvidia-current packages are still shown as available updates, but I wonder if letting them install would be a wise decision.
Posts: 6
Joined: Feb 17th, '19, 21:19

Re: [SOLVED] Update broke Nvidia driver

Postby doktor5000 » Feb 18th, '19, 19:44

Hi there, thanks for the feedback.

Just a quick question, did you maybe use the "Test" button in drakx11 at some point in time during this troubleshooting process? As that is probably the cause for this.
As an advice, don't use the "Test" button in drakx11, just select your driver, OK, then exit it and reboot

FWIW, this has already been reported, see e.g. https://bugs.mageia.org/show_bug.cgi?id=20835
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
Posts: 15022
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: [SOLVED] Update broke Nvidia driver

Postby marydou » Feb 20th, '19, 07:31

Though I did press the Test button a couple times during all this mess, I don't think I pressed it right before the login screen loop appeared.

Actually I found many reports of the same problem (login screen loop) appearing under different distributions, including mint, when people tried to update the nvidia driver, so maybe it isn't really drakx11 related.

Booting into kernel 4.14 (selected from grub) solved the virtualbox problem and nvidia driver was recompiled without problem at startup (though booting into 4.18 didn't cause other problems except virtualbox, so I could just keep using it as well).

I noticed that kernel 4.18 was installed from backport, which is strange as I haven't enabled backport repositories, so maybe this played a part in this?
Posts: 6
Joined: Feb 17th, '19, 21:19

Return to Video

Who is online

Users browsing this forum: No registered users and 1 guest