[SOLVED]Steam wont install, looking for libdbus-glib1_2

This forum is dedicated to testing early releases and cauldron : Howtos, tips, tricks and user global feedback and thoughts...

Helpful tip :
For bugs tracking we use : https://bugs.mageia.org = The Mageia Bug Tracker
In this bug tracker you'll find already reported bugs and you'll be able to report those you have found....

[SOLVED]Steam wont install, looking for libdbus-glib1_2

Postby canadaist » Dec 25th, '20, 21:36

Code: Select all
A requested package cannot be installed:
steam-1.0.0.68-1.mga8.nonfree.x86_64 (due to unsatisfied libdbus-glib1_2)

I have made sure that 32 bit repositories are enabled: core, nonfree and tainted, all with updates enabled.

It may be not ready yet.

If I had someone wanting to get up and playing quickly is there a work around?

Operating System: Mageia 8
KDE Plasma Version: 5.20.4
KDE Frameworks Version: 5.76.0
Qt Version: 5.15.2
Kernel Version: 5.10.2-desktop-1.mga8
OS Type: 64-bit
Processors: 8 × AMD Ryzen 7 4700U with Radeon Graphics
Memory: 15.1 GiB of RAM
Graphics Processor: AMD RENOIR


SOLUTION
I assume it was my error somehow, but ONLY the Updates for 32 bit core non free and tainted repos were enabled.
I enabled, steam installed, sorry to bother you.
canadaist
 
Posts: 157
Joined: May 7th, '11, 17:28

Re: [SOLVED]Steam wont install, looking for libdbus-glib1_2

Postby tis » Jan 9th, '21, 09:54

Hi,

What a mere chance that I've tried steam in these days. I found this when I read about games for Linux.
I've installed steam 1.0.0.61 1.mga7.nonfree x86_64 and steam-udevrules 1.0.0.61 1.mga7 x86_64 from Mageia Control Center.
Code: Select all
[RPM][30521]: install gnu-free-fonts-common-20120503-9.mga7.noarch: success
[RPM][30521]: install gnu-free-mono-fonts-20120503-9.mga7.noarch: success
[RPM][30521]: install steam-udevrules-1.0.0.61-1.mga7.noarch: success
[RPM][30521]: install libnghttp2_14-1.41.0-1.mga7.i586: success
[RPM][30521]: install libbrotlicommon1-1.0.7-2.1.mga7.i586: success
[RPM][30521]: install libbrotlidec1-1.0.7-2.1.mga7.i586: success
[RPM][30521]: install libssh4-1:0.8.9-1.1.mga7.i586: success
[RPM][30521]: install libmesaglu1-9.0.0-8.mga7.i586: success
[RPM][30521]: install libsasl2_3-2.1.27-1.1.mga7.i586: success
[RPM][30521]: install libldap2.4_2-2.4.50-1.2.mga7.i586: success
[RPM][30521]: install libcurl4-1:7.71.0-1.mga7.i586: success
[RPM][30521]: install steam-1.0.0.61-1.mga7.nonfree.x86_64: success

First it hadn't start. I went to console and started from there. It said there was some updates and it did everything.

Now it works well.

For security reason, my advice is use steam as a different user than you can access your personal data/documents/photos/files.
tis
 
Posts: 76
Joined: Sep 30th, '19, 20:19


Return to Testing : Alpha, Beta, RC and Cauldron

Who is online

Users browsing this forum: No registered users and 1 guest

cron