Update error Mageia8

This forum is dedicated to testing early releases and cauldron : Howtos, tips, tricks and user global feedback and thoughts...

Helpful tip :
For bugs tracking we use : https://bugs.mageia.org = The Mageia Bug Tracker
In this bug tracker you'll find already reported bugs and you'll be able to report those you have found....

Update error Mageia8

Postby Vanitarium » Aug 14th, '20, 13:21

Code: Select all
Installation failed:   file /usr/lib64/libGLESv2.so.2 from install of lib64glesv22-1.3.2-13.mga8.x86_64 conflicts with file from package lib64mesaglesv2_2-20.1.1-11.mga8.x86_64
   libsndio.so.7.1()(64bit) is needed by lib64openal1-1.20.1-4.mga8.x86_64
   gnome-shell >= 3.37.90 is needed by gnome-shell-extensions-common-3.37.90-1.mga8.noarch
   libpoppler.so.102()(64bit) is needed by lib64poppler-glib8-20.08.0-1.mga8.x86_64
   libsndio.so.7.1()(64bit) is needed by lib64sox3-14.4.3-0.git20200117.3.mga8.x86_64
   lib64glesv22 >= 1.3.1-7 is needed by lib64mesaglesv2_2-20.1.5-3.mga8.x86_64
   libGLESv2.so.2()(64bit) is needed by (installed) lib64mutter7_0-3.37.3-4.mga8.x86_64
   libGLESv2.so.2()(64bit) is needed by (installed) gnome-session-3.36.0-1.mga8.x86_64
   libpoppler.so.102()(64bit) is needed by libreoffice-pdfimport-1:6.4.5.2-3.mga8.x86_64
   libindicator3.so.7()(64bit) is needed by (installed) lib64appindicator3_1-12.10.0-22.mga8.x86_64



During the update it gave this error as listed above. Any ideas??? :oops: ;) ;)
ASUS Zenbook Flip 14 UM462DA with AMD RYZEN 5 3500u with radeon vega mobile gfx × 8
Vanitarium
 
Posts: 15
Joined: Aug 8th, '20, 22:46
Location: Falkland,Fife,SCOTLAND

Re: Update error Mageia8

Postby doktor5000 » Aug 14th, '20, 15:45

Either skip the mesa/lib64mesaglesv update, or try after enabling core/updates_testing repository.
This was already discussed on the dev mailing list: https://ml.mageia.org/l/arc/dev/2020-08/msg00019.html
You are encouraged to follow the mailing list if you're using cauldron to be informed about such breakages ...
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16072
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: Update error Mageia8

Postby Vanitarium » Aug 14th, '20, 15:59

Thanks doktor5000!
I am now subscribed and hoping I will not report any more bugs because they are well known although not always solved!!
ASUS Zenbook Flip 14 UM462DA with AMD RYZEN 5 3500u with radeon vega mobile gfx × 8
Vanitarium
 
Posts: 15
Joined: Aug 8th, '20, 22:46
Location: Falkland,Fife,SCOTLAND

Re: Update error Mageia8

Postby Vanitarium » Aug 14th, '20, 16:22

Did all the magic of mesa and core/updates you recommended. Got this at the end:

file /usr/lib64/libGLESv2.so.2 from install of lib64glesv22-1.3.2-13.mga8.x86_64 conflicts with file from package lib64mesaglesv2_2-20.1.1-11.mga8.x86_64

gnome-shell >= 3.37.90 is needed by gnome-shell-extensions-common-3.37.90-1.mga8.noarch

libsndio.so.7.1()(64bit) is needed by lib64openal1-1.20.1-4.mga8.x86_64

libpoppler.so.102()(64bit) is needed by lib64poppler-glib8-20.08.0-1.mga8.x86_64

libsndio.so.7.1()(64bit) is needed by lib64sox3-14.4.3-0.git20200117.3.mga8.x86_64


I just do not understand why I should report these errors if they are well known but not publicised. A simple public list of known bugs for the alpha distro would be of great help!!
ASUS Zenbook Flip 14 UM462DA with AMD RYZEN 5 3500u with radeon vega mobile gfx × 8
Vanitarium
 
Posts: 15
Joined: Aug 8th, '20, 22:46
Location: Falkland,Fife,SCOTLAND

Re: Update error Mageia8

Postby doktor5000 » Aug 14th, '20, 17:30

Most of that is due to the packages have requires themselves on newer mesa or have not been fixed yet.

Vanitarium wrote:A simple public list of known bugs for the alpha distro would be of great help!!

That also needs to be maintained. Maybe you want to help our triage team with that ? https://wiki.mageia.org/en/Bug_Squad

Maybe you should read https://wiki.mageia.org/en/Cauldron again. Such basic dependency issues due to ongoing updates are a regular part of cauldron.
I'd say feel free to report e.g. installer and blocker problems for the alpha/beta images, although an update afterwards is not part of the Mageia 8 alpha/beta, that is cauldron.
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16072
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany


Return to Testing : Alpha, Beta, RC and Cauldron

Who is online

Users browsing this forum: No registered users and 1 guest