Page 1 of 1

[solved]Network Manager: No wireless connection.

PostPosted: Nov 7th, '19, 21:51
by Bequimao
Network Manager: No wireless connection.

When trying to connect to a wireless connection with plasma-applet-nm, I get the following message:
"Networkmanagement - Failed to add connection
Connection <name> is not available on device wlp2s0 because profile is not compatible with device (device MAC address does not match the profile)"

The same connection works with Mageia 7. This is not my home network. I am not sure if worked before on my home connection. I am presently located in Brazil. The brazilian provider does not support IPv6.

Further info
Code: Select all
[root@mga8-cauldron ~]# systemctl list-units | grep -i network
  sys-devices-pci0000:00-0000:00:1c.0-0000:02:00.0-net-wlp2s0.device                              loaded active plugged   AR9485 Wireless Network Adapter (Unex DHXA-225)   
  sys-subsystem-net-devices-wlp2s0.device                                                         loaded active plugged   AR9485 Wireless Network Adapter (Unex DHXA-225)   
  NetworkManager-wait-online.service                                                              loaded active exited    Network Manager Wait Online                       
  NetworkManager.service                                                                          loaded active running   Network Manager                                   
  systemd-timesyncd.service                                                                       loaded active running   Network Time Synchronization                                                                                         loaded active active    Network is Online                                                                                                            loaded active active    Network                                           

[root@mga8-cauldron ~]# lspci -nnk | grep -iA3 wireless
02:00.0 Network controller [0280]: Qualcomm Atheros AR9485 Wireless Network Adapter [168c:0032] (rev 01)
        Subsystem: Foxconn International, Inc. Unex DHXA-225 [105b:e044]
        Kernel driver in use: ath9k
        Kernel modules: ath9k

Best regards,

Re: Network Manager: No wireless connection.

PostPosted: Nov 8th, '19, 14:40
by doktor5000
Can you post the full output when you try to establish the connection with
Code: Select all
nmcli con up <name>

and also the connection itself (excluding maybe the SSID or other such private details)
Code: Select all
nmcli con show <name>

From the error message it seems you should take a look at the following links: ... domization ... ss-to-eth0 ... ac-address

Another option would be to simply create a new connection from scratch, as it seems you're trying to connect to an already existing connection.

Re: Network Manager: No wireless connection.

PostPosted: Nov 9th, '19, 22:51
by Bequimao
Creating a new connection worked fine. I removed the files /etc/sysconfig/network-scripts/ifcfg-<name>* and could then simply connect to the wifi network.

I tried also to disable MAC address randomisation after the first link (Arch wiki), but that proofed to be not necessary. Reverted the change later.


Re: [solved]Network Manager: No wireless connection.

PostPosted: Jan 7th, '20, 06:20
by laidlaws
After the last update to Mageia8 (Cauldron) I have identical symptoms, but the above fix doesn't help. I have Cauldron as my default OS, and an earlier Cauldron installation to watch. When my default system wouldn't connect, my earlier system had no problem -- until I updated it. Now it shows the same condition. In addition the "Configure" menu that I can bring up by clicking on the applet, returns to the "Configure" prompt far too early. I can get a connection by running ifdown then ifup.

It looks like a recently introduced bug, but I am not sure which RPM to nominate on Bugzilla.