[SOLVED] The Slack app fails to start in Mageia Cauldron

This forum is dedicated to testing early releases and cauldron : Howtos, tips, tricks and user global feedback and thoughts...

Helpful tip :
For bugs tracking we use : https://bugs.mageia.org = The Mageia Bug Tracker
In this bug tracker you'll find already reported bugs and you'll be able to report those you have found....

[SOLVED] The Slack app fails to start in Mageia Cauldron

Postby Can80 » Nov 16th, '21, 19:25

Hello!
I am having a small issue with the Slack networking platform app, which usually works well in Mageia.
My desktop PC is currently running Mageia Cauldron X86_64 (kernel 5.15.2-desktop-2.mga9) with the Cinnamon environment.
I installed the Slack app (slack-4.13.0-0.1.fc21.x86_64.rpm) but I can't get the app to start.

When trying from the command line I get the following:
Code: Select all
$ slack
Initializing local storage instance
(node:110580) [DEP0005] DeprecationWarning: Buffer() is deprecated due to security and usability issues. Please use the Buffer.alloc(), Buffer.allocUnsafe(), or Buffer.from() methods instead.
(electron) Sending uncompressed crash reports is deprecated and will be removed in a future version of Electron. Set { compress: true } to opt-in to the new behavior. Crash reports will be uploaded gzipped, which most crash reporting servers support.
(electron) 'BrowserWindow.getDevToolsExtensions' is deprecated and will be removed. Please use 'session.getAllExtensions' instead.
[11/16/21, 11:48:30:589] info:
╔════════════════════════════════════════════════════════════╗
║      Slack 4.13.0, linux 5.15.2-desktop-2.mga9 on x64      ║
╚════════════════════════════════════════════════════════════╝
[11/16/21, 11:48:30:590] info: Configured logger via
{
  "enableConsoleTransport": true,
  "identifierOverride": "webapp-service-worker-console",
  "shouldUseNewBackend": false,
  "loggerInstanceCount": 2
}
[11/16/21, 11:48:30:590] info: Predefined values for process
{
  "NODE_ENV": "production",
  "platform": "linux",
  "type": "browser",
  "PACKAGE_MANIFEST.productName": "Slack",
  "PACKAGE_MANIFEST.version": "4.13.0",
  "PACKAGE_MANIFEST.commit": "1a1dd06",
  "PACKAGE_MANIFEST.branch": "HEAD",
  "PACKAGE_MANIFEST.useSentry": true
}
[110580:1116/114830.821631:FATAL:gpu_data_manager_impl_private.cc(445)] GPU process isn't usable. Goodbye.

Unexpected crash report id length
Failed to get crash dump id.
Report Id:

Unexpected crash report id length
Failed to get crash dump id.
Report Id:
Illegal instruction (core dumped)


So Slack crashes and I suspect that the issue is related to this warning " 'BrowserWindow.getDevToolsExtensions' is deprecated and will be removed. Please use 'session.getAllExtensions' instead."
which I don't know what it means.
In contrast, running the app on Mageia 8 stable X86_64 (kernel 5.14.17-desktop-1.mga8), Cinnamon works as expected. I don't get the warning above, nor a fatal error (obviously).

I'm looking around to find out how to fix this, but if anybody has clues to provide me, I will gladly welcome it. :)

Many thanks for your time!
Last edited by Can80 on Nov 17th, '21, 17:59, edited 2 times in total.
Can80
 
Posts: 20
Joined: Sep 18th, '18, 21:19
Location: Québec, Canada

Re: The Slack app fails to start in Mageia Cauldron

Postby sturmvogel » Nov 16th, '21, 22:12

As far i can see slack is not a package provided by Mageia. The only thing obvious for me is, that you are using an outdated version of slack. Did you try to install the actual version 4.21.1? There where many bugfixes in the versions in between:
https://slack.com/release-notes/linux

Also the message that you mentioned: This is only an information/warning. The reason for your crash is:
Code: Select all
[110580:1116/114830.821631:FATAL:gpu_data_manager_impl_private.cc(445)] GPU process isn't usable. Goodbye.


You could also try to start slack with following parameter:
Code: Select all
--disable-gpu-sandbox
sturmvogel
 
Posts: 188
Joined: Jul 30th, '12, 00:39

Re: The Slack app fails to start in Mageia Cauldron

Postby doktor5000 » Nov 16th, '21, 23:17

Can80 wrote:
[110580:1116/114830.821631:FATAL:gpu_data_manager_impl_private.cc(445)] GPU process isn't usable. Goodbye.

[...]

So Slack crashes and I suspect that the issue is related to this warning " 'BrowserWindow.getDevToolsExtensions' is deprecated and will be removed. Please use 'session.getAllExtensions' instead."

No, that's only verbose output. The issue seems to be with your X session or graphics driver / acceleration, see the FATAL error above.

Something similar has also been reported here: https://bugs.launchpad.net/ubuntu/+sour ... ug/1943568
Seems to be an electron issue, you'd need to wait for a new version or disable the sandbox in between: https://github.com/electron/electron/pull/31091
Cauldron is not for the faint of heart!
Caution: Hot, bubbling magic inside. May explode or cook your kittens!
----
Disclaimer: Beware of allergic reactions in answer to unconstructive complaint-type posts
User avatar
doktor5000
 
Posts: 16877
Joined: Jun 4th, '11, 10:10
Location: Leipzig, Germany

Re: The Slack app fails to start in Mageia Cauldron

Postby Can80 » Nov 17th, '21, 17:59

sturmvogel wrote:Did you try to install the actual version 4.21.1?

Oh my. I did not realize that the version of slack I had installed was so old. How embarrassing... :oops:
Installing the latests version did indeed the trick, as both of you suggested.

Thank you very much for your kind help, I really appreciate it!
Can80
 
Posts: 20
Joined: Sep 18th, '18, 21:19
Location: Québec, Canada


Return to Testing : Alpha, Beta, RC and Cauldron

Who is online

Users browsing this forum: No registered users and 1 guest