[RESOLVED]Many packages removed by Mageia 7 beta 1 update

This forum is dedicated to testing early releases and cauldron : Howtos, tips, tricks and user global feedback and thoughts...

Helpful tip :
For bugs tracking we use : https://bugs.mageia.org = The Mageia Bug Tracker
In this bug tracker you'll find already reported bugs and you'll be able to report those you have found....

[RESOLVED]Many packages removed by Mageia 7 beta 1 update

Postby banjo » Jan 8th, '19, 16:45

Please excuse me if this is a dumb question, but I am new to Cauldron so not sure what to expect.

Yesterday, Jan 7, I installed a huge update that removed many packages from my installation. Some of those packages were installed by me, and others came along as defaults with the installation. Here is the list.

Code: Select all
blender-2.79b-10.mga7.x86_64
digikam-5.9.0-4.mga7.x86_64
fontforge-20170731-7.mga7.x86_64
frescobaldi-3.0.0-4.mga7.noarch
hplip-3.18.12-3.mga7.x86_64
hplip-gui-3.18.12-3.mga7.x86_64
isodumper-1.05-2.mga7.noarch
isodumper-qt-1.05-2.mga7.noarch
lensfun-0.3.2-5.mga7.x86_64
lib64audaspace1-1.3.0-16.mga7.x86_64
lib64digikamcore5-5.9.0-4.mga7.x86_64
lib64digikamdatabase5-5.9.0-4.mga7.x86_64
lib64digikamgui5-5.9.0-4.mga7.x86_64
lib64lensfun1-0.3.2-5.mga7.x86_64
lib64python3.6-3.6.7-3.mga7.x86_64
lib64python3.6-stdlib-3.6.7-3.mga7.x86_64
libreoffice-base-6.1.4.2-2.mga7.x86_64
libreoffice-calc-6.1.4.2-2.mga7.x86_64
libreoffice-draw-6.1.4.2-2.mga7.x86_64
libreoffice-impress-6.1.4.2-2.mga7.x86_64
libreoffice-math-6.1.4.2-2.mga7.x86_64
libreoffice-pdfimport-6.1.4.2-2.mga7.x86_64
libreoffice-pyuno-6.1.4.2-2.mga7.x86_64
libreoffice-writer-6.1.4.2-2.mga7.x86_64
mageiawelcome-1.90-1.mga7.noarch
net_monitor-0.24-3.mga7.x86_64
python-odf-tools-1.3.6-2.mga7.noarch
python3-audaspace-1.3.0-16.mga7.x86_64
python3-cups-1.9.74-1.mga7.x86_64
python3-curl-7.43.0.1-2.mga7.x86_64
python3-gnupg-0.4.3-2.mga7.noarch
python3-ly-0.9.5-5.mga7.noarch
python3-odf-1.3.6-2.mga7.noarch
python3-olefile-0.44-2.mga7.noarch
python3-opengl-3.1.0-9.mga7.x86_64
python3-parted-3.10.7-5.mga7.x86_64
python3-poppler-qt5-0.24.2-4.mga7.x86_64
python3-pydbus-0.6.0-2.mga7.noarch
python3-reportlab-3.5.12-1.mga7.x86_64
python3-smbc-1.0.15.8-4.mga7.x86_64
python3-yui-1.1.2-5.mga7.x86_64
sigil-0.9.10-3.mga7.x86_64
system-config-printer-1.5.11-1.mga7.x86_64
system-config-printer-libs-1.5.11-1.mga7.noarch
system-config-printer-udev-1.5.11-1.mga7.x86_64
task-printing-2018-4.mga7.x86_64
task-printing-hp-2018-4.mga7.x86_64
task-printing-scanning-2018-4.mga7.x86_64
ufraw-gimp-0.22-10.mga7.x86_64


Core packages such as LibreOffice, Mageia Welcome and Hplip are now gone from this installation.

When I try to install the packages, MCC throws an error saying they cannot beselected.

Code: Select all
Sorry, the following package cannot be selected:

- hplip-3.18.12-3.mga7.x86_64 (due to unsatisfied python(abi)[== 3.6])


Is this an expected result from this update, or did I push a wrong button somehow?

Thanks
Banjo
(_)=='=~
Last edited by banjo on Jan 14th, '19, 17:53, edited 1 time in total.
If only the best bird sang, the forest would be a very quiet place.
User avatar
banjo
 
Posts: 150
Joined: May 4th, '11, 03:50
Location: Reading, Massachusetts

Re: Many packages removed by Mageia 7 beta 1 update

Postby isadora » Jan 8th, '19, 16:57

As what is to be found in the mailing-list (gmane.linux.mageia.devel):
Cauldron is in the middle of being upgraded to Python 3.7.


Tried update for Cauldron in my VM, and got following.

Code: Select all
The following packages have to be removed for others to be upgraded:
digikam-5.9.0-4.mga7.x86_64
 (due to missing libdigikamcore.so.5.9.0()(64bit),
  due to missing libdigikamdatabase.so.5.9.0()(64bit),
  due to missing libdigikamgui.so.5.9.0()(64bit),
  due to unsatisfied digikam-core == 1:5.9.0-4.mga7)
lensfun-0.3.2-5.mga7.x86_64
 (due to unsatisfied python(abi) == 3.6)
lib64digikamcore5-5.9.0-4.mga7.x86_64
 (due to missing liblensfun.so.1()(64bit))
lib64digikamdatabase5-5.9.0-4.mga7.x86_64
 (due to missing libdigikamcore.so.5.9.0()(64bit))
lib64digikamgui5-5.9.0-4.mga7.x86_64
 (due to missing libdigikamcore.so.5.9.0()(64bit),
  due to missing libdigikamdatabase.so.5.9.0()(64bit))
lib64lensfun1-0.3.2-5.mga7.x86_64
 (due to missing lensfun)
lib64python3.6-3.6.7-3.mga7.x86_64
 (due to unsatisfied lib64python3.6-stdlib == 3.6.7-3.mga7)
lib64python3.6-stdlib-3.6.7-3.mga7.x86_64
 (due to unsatisfied python(abi) == 3.6,
  due to missing libpython3.6m.so.1.0()(64bit))
libreoffice-base-6.1.4.2-2.mga7.x86_64
 (due to unsatisfied libreoffice-pyuno(x86-64) == 1:6.1.4.2-2.mga7,
  due to unsatisfied libreoffice-calc(x86-64) == 1:6.1.4.2-2.mga7,
  due to missing libforlo.so()(64bit),
  due to missing libforuilo.so()(64bit))
libreoffice-calc-6.1.4.2-2.mga7.x86_64
 (due to unsatisfied libreoffice-pyuno(x86-64) == 1:6.1.4.2-2.mga7)
libreoffice-draw-6.1.4.2-2.mga7.x86_64
 (due to unsatisfied libreoffice-pyuno(x86-64) == 1:6.1.4.2-2.mga7,
  due to unsatisfied libreoffice-pdfimport(x86-64) == 1:6.1.4.2-2.mga7)
libreoffice-impress-6.1.4.2-2.mga7.x86_64
 (due to unsatisfied libreoffice-pyuno(x86-64) == 1:6.1.4.2-2.mga7)
libreoffice-math-6.1.4.2-2.mga7.x86_64
 (due to unsatisfied libreoffice-pyuno(x86-64) == 1:6.1.4.2-2.mga7)
libreoffice-pdfimport-6.1.4.2-2.mga7.x86_64
 (due to unsatisfied libreoffice-draw(x86-64) == 1:6.1.4.2-2.mga7)
libreoffice-pyuno-6.1.4.2-2.mga7.x86_64
 (due to unsatisfied python(abi) == 3.6,
  due to missing libpython3.6m.so.1.0()(64bit))
libreoffice-writer-6.1.4.2-2.mga7.x86_64
 (due to unsatisfied libreoffice-pyuno(x86-64) == 1:6.1.4.2-2.mga7)
mageiawelcome-1.20-1.mga7.noarch
 (due to unsatisfied python(abi) == 3.6,
  due to missing python3-opengl)
python3-opengl-3.1.0-9.mga7.x86_64
 (due to unsatisfied python(abi) == 3.6,
  due to missing libpython3.6m.so.1.0()(64bit))
ufraw-gimp-0.22-10.mga7.x86_64
 (due to missing liblensfun.so.1()(64bit))


And so decided to skip for the moment.
..........bird from paradise..........

Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.
—Antoine de Saint-Exupéry
User avatar
isadora
 
Posts: 2402
Joined: Mar 25th, '11, 16:03
Location: Amsterdam, the Netherlands

Re: Many packages removed by Mageia 7 beta 1 update

Postby banjo » Jan 8th, '19, 17:47

Thanks for the info. I am not hooked into the mailing list, so didn't see that.

That message is similar to the one that I got. However, I said, "Sure. Go ahead" and it all disappeared. :shock:

I will see about re-installing the apps after the upgrade is done.
If only the best bird sang, the forest would be a very quiet place.
User avatar
banjo
 
Posts: 150
Joined: May 4th, '11, 03:50
Location: Reading, Massachusetts

Re: Many packages removed by Mageia 7 beta 1 update

Postby isadora » Jan 8th, '19, 19:28

For information concerning aforementioned:
https://ml.mageia.org/l/arc/dev/2019-01/
..........bird from paradise..........

Perfection is achieved, not when there is nothing more to add, but when there is nothing left to take away.
—Antoine de Saint-Exupéry
User avatar
isadora
 
Posts: 2402
Joined: Mar 25th, '11, 16:03
Location: Amsterdam, the Netherlands

Re: Many packages removed by Mageia 7 beta 1 update

Postby banjo » Jan 8th, '19, 20:44

Thanks for the link. Interesting conversation.
If only the best bird sang, the forest would be a very quiet place.
User avatar
banjo
 
Posts: 150
Joined: May 4th, '11, 03:50
Location: Reading, Massachusetts


Return to Testing : Alpha, Beta, RC and Cauldron

Who is online

Users browsing this forum: No registered users and 1 guest