[gelöst]FreeCAD OpenCAMLib cmake error:Could NOT find OpenMP

Dieses Forum ist für die erweiterte Hilfe und Unterstützung vorgesehen:

Bitte stelle hier Deine Fragen zur fortgeschrittenen Benutzung von Mageia. Beispielsweise geht es hier um Fragen zum Netzwerk, automatischen Installationen, komplexer Serverkonfiguration, Kerneltuning, Aufsetzen eines Mageia-Mirrors, kurz gesagt: alle Aufgaben, die auch für erfahrene Benutzer eine Herausforderung sind.

[gelöst]FreeCAD OpenCAMLib cmake error:Could NOT find OpenMP

Beitragvon lukas » Apr 7th, '19, 18:20

Hallo

Ich nutze FreeCAD unter Mageia 6.1
Nun würde ich gerne 3D GCode Daten für meine Fräse generieren.
Leider wird dafür eine externe Lib benötigt: opencamlib

https://github.com/aewallin/opencamlib

Für Linux muss man diese Lib leider selbst bauen.

Bekomme nun den Fehler "Could NOT find OpenMP"
gcc 5 sollte OpenMP unterstützen. https://gcc.gnu.org/wiki/openmp
In Forenbeiträgen mit OpenMP Problemen wird häufig libgomp erwähnt, scheint aber im gcc rpm dabei zu sein: https://madb.mageia.org/rpm/show/applic ... /t_media/4

Im git steht noch, dass folgendes benötigt wird, aber soweit komm ich noch gar nicht.
build-essential -> mageia rpm-build installiert
cmake -> 3.7.2 installiert
subversion
doxygen
texlive-latex-base
libboost-all-dev -> vermutlich mein nächstes Problem, konnte ich auch noch nicht finden.

Code: Alles auswählen
# cmake ../src
--  Note: will NOT build python library
--  Note: will NOT build emscripten library
-- C++ compiler version: 5.5.0 [/usr/bin/c++]
-- setting gcc options: -Wall  -Wno-deprecated -pedantic-errors
-- Try OpenMP C flag = [-fopenmp]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Failed
-- Try OpenMP C flag = [ ]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Failed
-- Try OpenMP C flag = [-fopenmp=libomp]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Failed
-- Try OpenMP C flag = [/openmp]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Failed
-- Try OpenMP C flag = [-Qopenmp]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Failed
-- Try OpenMP C flag = [-openmp]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Failed
-- Try OpenMP C flag = [-xopenmp]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Failed
-- Try OpenMP C flag = [+Oopenmp]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Failed
-- Try OpenMP C flag = [-qsmp]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Failed
-- Try OpenMP C flag = [-mp]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Failed
-- Try OpenMP CXX flag = [-fopenmp]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Failed
-- Try OpenMP CXX flag = [ ]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Failed
-- Try OpenMP CXX flag = [-fopenmp=libomp]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Failed
-- Try OpenMP CXX flag = [/openmp]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Failed
-- Try OpenMP CXX flag = [-Qopenmp]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Failed
-- Try OpenMP CXX flag = [-openmp]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Failed
-- Try OpenMP CXX flag = [-xopenmp]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Failed
-- Try OpenMP CXX flag = [+Oopenmp]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Failed
-- Try OpenMP CXX flag = [-qsmp]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Failed
-- Try OpenMP CXX flag = [-mp]
-- Performing Test OpenMP_FLAG_DETECTED
-- Performing Test OpenMP_FLAG_DETECTED - Failed
CMake Error at /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:138 (message):
  Could NOT find OpenMP (missing: OpenMP_C_FLAGS OpenMP_CXX_FLAGS)
Call Stack (most recent call first):
  /usr/share/cmake/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake/Modules/FindOpenMP.cmake:316 (find_package_handle_standard_args)
  CMakeLists.txt:101 (find_package)


-- Configuring incomplete, errors occurred!
See also "/home/luki/Downloads/opencamlib/opencamlib/build/CMakeFiles/CMakeOutput.log".
See also "/home/luki/Downloads/opencamlib/opencamlib/build/CMakeFiles/CMakeError.log".


Danke für Euer Mühe

lg Lukas
Zuletzt geändert von lukas am Apr 12th, '19, 18:21, insgesamt 4-mal geändert.
lukas
 
Beiträge: 25
Registriert: Mär 7th, '12, 14:21

Re: FreeCAD OpenCAMLib cmake error:Could NOT find OpenMP

Beitragvon doktor5000 » Apr 7th, '19, 22:57

Hallo,

also die im git genannten Paketnamen sind für Debian-Systeme. Der Rest sollte sich installieren lassen als root via

Code: Alles auswählen
urpmi subversion subversion 'devel(libgomp)' boost-devel


Bei texlive-latex-base bin ich mir nicht sicher was da genau benötigt wird, ob nicht evtl. nur die Binary davon ausreicht, aber installier erstmal oben die Pakete und dann versuch nochmal
Ich bin nicht böse, sondern nur ehrlich. Und wer lesen kann, ist klar im Vorteil.
----
Mageia - the magic continues
Benutzeravatar
doktor5000
 
Beiträge: 5092
Registriert: Jun 2nd, '11, 09:39

Re: FreeCAD OpenCAMLib cmake error:Could NOT find OpenMP

Beitragvon lukas » Apr 8th, '19, 17:16

Hallo

Danke für deine Antwort

urpmi subversion subversion 'devel(libgomp)' boost-devel

habe ich ausgeführt, folgende Meldung bekomme ich:
Einige Pakete wurden eventuell installiert, es sind aber Fehler aufgetreten.
Das folgende Paket kann nicht installiert werden, weil es von Paketen
abhängt, die älter sind als die installierten Pakete:
libgomp-devel-5.5.0-1.mga6
Wollen Sie trotzdem fortfahren?


Mit cmake kommt leider immer noch der OpenMP Fehler

Habe das ganze in einer Ubuntu VM erneut versucht, dort hat alles funktioniert.
Vermute aber, dass die lib nicht einfach auf Mageia kopierbar ist, oder?

Danke
lukas
 
Beiträge: 25
Registriert: Mär 7th, '12, 14:21

Re: FreeCAD OpenCAMLib cmake error:Could NOT find OpenMP

Beitragvon doktor5000 » Apr 9th, '19, 01:11

lukas hat geschrieben:
Einige Pakete wurden eventuell installiert, es sind aber Fehler aufgetreten.
Das folgende Paket kann nicht installiert werden, weil es von Paketen
abhängt, die älter sind als die installierten Pakete:
libgomp-devel-5.5.0-1.mga6
Wollen Sie trotzdem fortfahren?




Bitte mal die Ausgabe von
Code: Alles auswählen
rpm -qa|grep -i gomp

Du hast das 32bit-Paket installiert, das müsstest du händisch deinstallieren bevor du das 64bit-Paket installieren kannst.

Ansonsten bitte mal die volle Ausgabe von
Code: Alles auswählen
urpmq --list-media active --list-url
urpmi --debug 'devel(libgomp)'
Ich bin nicht böse, sondern nur ehrlich. Und wer lesen kann, ist klar im Vorteil.
----
Mageia - the magic continues
Benutzeravatar
doktor5000
 
Beiträge: 5092
Registriert: Jun 2nd, '11, 09:39

Re: FreeCAD OpenCAMLib cmake error:Could NOT find OpenMP

Beitragvon lukas » Apr 9th, '19, 17:39

Ja, das klingt plausibel.
Vermutlich habe ich die sogar selbst falsch nachinstalliert, grr.

Code: Alles auswählen
#
# rpm -qa|grep -i gomp
libgomp1-8.3.1-0.20190405.1.mga7


Code: Alles auswählen
urpmq --list-media active --list-url
Core Release (distrib1) ftp://ftp-stud.hs-esslingen.de/pub/Mirrors/Mageia/distrib/6/x86_64/media/core/release
Core Updates (distrib3) ftp://ftp-stud.hs-esslingen.de/pub/Mirrors/Mageia/distrib/6/x86_64/media/core/updates
Nonfree Release (distrib11) ftp://ftp-stud.hs-esslingen.de/pub/Mirrors/Mageia/distrib/6/x86_64/media/nonfree/release
Nonfree Updates (distrib13) ftp://ftp-stud.hs-esslingen.de/pub/Mirrors/Mageia/distrib/6/x86_64/media/nonfree/updates
Core 32bit Release (distrib31) ftp://ftp-stud.hs-esslingen.de/pub/Mirrors/Mageia/distrib/6/i586/media/core/release
Core 32bit Updates (distrib32) ftp://ftp-stud.hs-esslingen.de/pub/Mirrors/Mageia/distrib/6/i586/media/core/updates
Nonfree 32bit Release (distrib36) ftp://ftp-stud.hs-esslingen.de/pub/Mirrors/Mageia/distrib/6/i586/media/nonfree/release
Nonfree 32bit Updates (distrib37) ftp://ftp-stud.hs-esslingen.de/pub/Mirrors/Mageia/distrib/6/i586/media/nonfree/updates


Code: Alles auswählen
urpmi --debug 'devel(libgomp)'
getting lock on urpmi
parsing: /etc/urpmi/mediacfg.d/Official-6-x86_64
Synthese-Datei [/var/lib/urpmi/Core Release (distrib1)/synthesis.hdlist.cz] wird gelesen
Synthese-Datei [/var/lib/urpmi/Core Updates (distrib3)/synthesis.hdlist.cz] wird gelesen
Synthese-Datei [/var/lib/urpmi/Nonfree Release (distrib11)/synthesis.hdlist.cz] wird gelesen
Synthese-Datei [/var/lib/urpmi/Nonfree Updates (distrib13)/synthesis.hdlist.cz] wird gelesen
Synthese-Datei [/var/lib/urpmi/Core 32bit Release (distrib31)/synthesis.hdlist.cz] wird gelesen
Synthese-Datei [/var/lib/urpmi/Core 32bit Updates (distrib32)/synthesis.hdlist.cz] wird gelesen
Synthese-Datei [/var/lib/urpmi/Nonfree 32bit Release (distrib36)/synthesis.hdlist.cz] wird gelesen
Synthese-Datei [/var/lib/urpmi/Nonfree 32bit Updates (distrib37)/synthesis.hdlist.cz] wird gelesen
getting exclusive lock on rpm
search_packages: found libgomp-devel-5.4.0-5.mga6.x86_64 matching devel(libgomp)
search_packages: found libgomp-devel-5.5.0-1.mga6.x86_64 matching devel(libgomp)
found package(s): libgomp-devel-5.4.0-5.mga6.x86_64 libgomp-devel-5.5.0-1.mga6.x86_64
opening rpmdb (root=, write=)
chosen libgomp-devel-5.5.0-1.mga6.x86_64 for libgomp-devel|libgomp-devel
selecting libgomp-devel-5.5.0-1.mga6.x86_64
requiring libgomp1[== 5.5.0-1.mga6] for libgomp-devel-5.5.0-1.mga6.x86_64
chosen libgomp1-5.5.0-1.mga6.x86_64 for libgomp1[== 5.5.0-1.mga6]
the more recent libgomp1-8.3.1-0.20190405.1.mga7.x86_64 is installed, but does not provide libgomp1[== 5.5.0-1.mga6] whereas libgomp1-5.5.0-1.mga6.x86_64 does
selecting libgomp1-5.5.0-1.mga6.x86_64
unselecting libgomp1-5.5.0-1.mga6.x86_64
unselecting libgomp-devel-5.5.0-1.mga6.x86_64
Das folgende Paket kann nicht installiert werden, weil es von Paketen
abhängt, die älter sind als die installierten Pakete:
libgomp-devel-5.5.0-1.mga6
Wollen Sie trotzdem fortfahren? (J/n) j
scheduled sets of transactions:
unlocking urpmi database
unlocking rpm database
Einige Pakete wurden eventuell installiert, es sind aber Fehler aufgetreten.
Das folgende Paket kann nicht installiert werden, weil es von Paketen
abhängt, die älter sind als die installierten Pakete:
libgomp-devel-5.5.0-1.mga6
Wollen Sie trotzdem fortfahren?
EXITING (pid=17825)


Habe mal versucht die lib zu deinstallieren, scheint aber von sehr vielen Programmen verwendet zu werden:

Code: Alles auswählen
# urpme libgomp1-8.3.1-0.20190405.1.mga7
Um die Abhängigkeiten zu erfüllen, werden die folgenden 33 Pakete entfernt (799MB):
  calibre-3.27.1-2.mga6.x86_64
   (wegen fehlendem ImageMagick)
  darktable-2.4.4-1.mga6.x86_64
   (wegen fehlendem libgomp.so.1()(64bit),
    wegen fehlendem libgomp.so.1(GOMP_1.0)(64bit),
    wegen fehlendem libgomp.so.1(GOMP_4.0)(64bit),
    wegen fehlendem libgomp.so.1(OMP_1.0)(64bit),
    wegen fehlendem libGraphicsMagick.so.3()(64bit))
  digikam-5.9.0-1.mga6.x86_64
   (wegen fehlendem hugin,
    wegen fehlendem libdigikamcore.so.5.9.0()(64bit),
    wegen fehlendem libdigikamdatabase.so.5.9.0()(64bit),
    wegen nicht erfüllter Abhängigkeit von digikam-core == 1:5.9.0-1.mga6 ,
    wegen fehlendem libdigikamgui.so.5.9.0()(64bit))
  dvdauthor-0.7.2-2.2.mga6.x86_64
   (wegen fehlendem libMagickCore-6.Q16.so.6()(64bit))
  enblend-4.2-1.mga6.x86_64
   (wegen fehlendem libgomp.so.1()(64bit),
    wegen fehlendem libgomp.so.1(GOMP_1.0)(64bit),
    wegen fehlendem libgomp.so.1(GOMP_4.0)(64bit),
    wegen fehlendem libgomp.so.1(OMP_1.0)(64bit),
    wegen fehlendem libgomp.so.1(OMP_3.0)(64bit))
  gettext-0.19.8.1-1.1.mga6.x86_64
   (wegen fehlendem libgomp.so.1()(64bit),
    wegen fehlendem libgomp.so.1(GOMP_1.0)(64bit),
    wegen fehlendem libgomp.so.1(GOMP_4.0)(64bit))
  hugin-2016.2.0-3.mga6.x86_64
   (wegen fehlendem libgomp.so.1()(64bit),
    wegen fehlendem libgomp.so.1(GOMP_1.0)(64bit),
    wegen fehlendem libgomp.so.1(GOMP_4.0)(64bit),
    wegen fehlendem libgomp.so.1(OMP_1.0)(64bit),
    wegen fehlendem libgomp.so.1(OMP_3.0)(64bit),
    wegen fehlendem enblend)
  imagemagick-6.9.10.33-1.mga6.x86_64
   (wegen fehlendem libgomp.so.1()(64bit),
    wegen fehlendem libgomp.so.1(GOMP_1.0)(64bit),
    wegen fehlendem libgomp.so.1(GOMP_4.0)(64bit),
    wegen fehlendem libgomp.so.1(OMP_1.0)(64bit),
    wegen nicht erfüllter Abhängigkeit von lib64magick-6Q16_6 == 6.9.10.33 ,
    wegen fehlendem libMagickCore-6.Q16.so.6()(64bit),
    wegen fehlendem libMagickWand-6.Q16.so.6()(64bit))
  inkscape-0.92.1-2.2.mga6.x86_64
   (wegen fehlendem libgomp.so.1()(64bit),
    wegen fehlendem libgomp.so.1(GOMP_4.0)(64bit),
    wegen fehlendem libgomp.so.1(OMP_1.0)(64bit),
    wegen fehlendem libMagickCore-6.Q16.so.6()(64bit),
    wegen fehlendem libMagickWand-6.Q16.so.6()(64bit),
    wegen fehlendem libMagick++-6.Q16.so.8()(64bit))
  k3b-17.12.2-1.mga6.x86_64
   (wegen fehlendem sox)
  k3d-0.8.0.5-5.2.mga6.x86_64
   (wegen fehlendem libMagick++-6.Q16.so.8()(64bit))
  lib64digikamcore5-5.9.0-1.mga6.x86_64
   (wegen fehlendem libgomp.so.1()(64bit),
    wegen fehlendem libgomp.so.1(GOMP_1.0)(64bit),
    wegen fehlendem libgomp.so.1(GOMP_4.0)(64bit),
    wegen fehlendem libgomp.so.1(OMP_1.0)(64bit))
  lib64digikamdatabase5-5.9.0-1.mga6.x86_64
   (wegen fehlendem libdigikamcore.so.5.9.0()(64bit))
  lib64digikamgui5-5.9.0-1.mga6.x86_64
   (wegen fehlendem libdigikamcore.so.5.9.0()(64bit),
    wegen fehlendem libdigikamdatabase.so.5.9.0()(64bit))
  lib64graphicsmagick3-1.3.31-1.4.mga6.x86_64
   (wegen fehlendem libgomp.so.1()(64bit),
    wegen fehlendem libgomp.so.1(GOMP_1.0)(64bit),
    wegen fehlendem libgomp.so.1(GOMP_4.0)(64bit),
    wegen fehlendem libgomp.so.1(OMP_1.0)(64bit))
  lib64magick++-6Q16_8-6.9.10.33-1.mga6.x86_64
   (wegen fehlendem libMagickCore-6.Q16.so.6()(64bit),
    wegen fehlendem libMagickWand-6.Q16.so.6()(64bit))
  lib64magick-6Q16_6-6.9.10.33-1.mga6.x86_64
   (wegen fehlendem libgomp.so.1()(64bit),
    wegen fehlendem libgomp.so.1(GOMP_1.0)(64bit),
    wegen fehlendem libgomp.so.1(GOMP_4.0)(64bit),
    wegen fehlendem libgomp.so.1(OMP_1.0)(64bit),
    wegen fehlendem libgomp.so.1(OMP_3.0)(64bit))
  lib64sox3-14.4.2-7.3.mga6.x86_64
   (wegen fehlendem libgomp.so.1()(64bit),
    wegen fehlendem libgomp.so.1(GOMP_1.0)(64bit),
    wegen fehlendem libgomp.so.1(GOMP_4.0)(64bit),
    wegen fehlendem libgomp.so.1(OMP_1.0)(64bit),
    wegen fehlendem libgomp.so.1(OMP_3.0)(64bit))
  libgomp1-8.3.1-0.20190405.1.mga7.x86_64
  lsb-core-lib64-4.1-20.mga6.x86_64
   (wegen fehlendem lsb-core-noarch)
  lsb-core-noarch-4.1-20.mga6.x86_64
   (wegen fehlendem gettext)
  lsb-lib64-4.1-20.mga6.x86_64
   (wegen fehlendem lsb-core-lib64)
  mlt-6.4.1-3.mga6.x86_64
   (wegen fehlendem libsox.so.3()(64bit))
  msec-2.6-1.mga6.x86_64
   (wegen fehlendem gettext)
  msec-gui-2.6-1.mga6.x86_64
   (wegen fehlendem msec)
  playonlinux-4.2.12-1.mga6.x86_64
   (wegen fehlendem gettext,
    wegen fehlendem imagemagick)
  rpm-build-4.13.1-3.2.mga6.x86_64
   (wegen nicht erfüllter Abhängigkeit von rpm-mageia-setup-build >= 1.34 )
  rpm-mageia-setup-build-2.20.1-1.mga6.x86_64
   (wegen fehlendem spec-helper)
  scribus-1.5.2-6.mga6.x86_64
   (wegen fehlendem libGraphicsMagick.so.3()(64bit))
  sectool-0.9.5-13.mga6.x86_64
   (wegen fehlendem gettext)
  sox-14.4.2-7.3.mga6.x86_64
   (wegen fehlendem libsox.so.3()(64bit))
  spec-helper-0.31.11-1.mga6.noarch
   (wegen fehlendem gettext)
  ufraw-gimp-0.22-5.mga6.x86_64
   (wegen fehlendem libgomp.so.1()(64bit),
    wegen fehlendem libgomp.so.1(GOMP_1.0)(64bit),
    wegen fehlendem libgomp.so.1(GOMP_4.0)(64bit),
    wegen fehlendem libgomp.so.1(OMP_1.0)(64bit))
Entfernen von 33 Paketen? (j/N) n


Wie ändere ich das nun möglichst ohne Folgeschäden?

Danke für deine Mühe
lukas
 
Beiträge: 25
Registriert: Mär 7th, '12, 14:21

Re: FreeCAD OpenCAMLib cmake error:Could NOT find OpenMP

Beitragvon sturmvogel » Apr 10th, '19, 04:42

Warum befindet sich ein Mageia7 Paket auf deiner Mageia6.1 -Installation?
sturmvogel
 
Beiträge: 59
Registriert: Jul 29th, '12, 23:40

Re: FreeCAD OpenCAMLib cmake error:Could NOT find OpenMP

Beitragvon lukas » Apr 10th, '19, 07:34

Vermutlich habe ich diese lib mal gesucht, nicht gefunden und selbst nachinstalliert.

Woher weiß ich, dass ich ein devel paket benötige?
Sucht der Befehl urpmi devel() nach diesen paketen?
Wieder etwas dazu gelernt, gibt es dazu wo eine Erklärung?

Wie löse ich das nun?
eventuell urpmi --downgrade?
Aber wie heißt das korrekte Paket, wie finde ich das heraus?

woher weiß urpmi anhand devel(libgomp) welche version korrekt ist?

Danke
lukas
 
Beiträge: 25
Registriert: Mär 7th, '12, 14:21

Re: FreeCAD OpenCAMLib cmake error:Could NOT find OpenMP

Beitragvon doktor5000 » Apr 11th, '19, 13:59

lukas hat geschrieben:Woher weiß ich, dass ich ein devel paket benötige?
Sucht der Befehl urpmi devel() nach diesen paketen?
Wieder etwas dazu gelernt, gibt es dazu wo eine Erklärung?

Wenn du etwas kompilieren willst, dann brauchst du dazu nicht nur die Bibliothek selber, sondern auch die Header-Dateien. Die sind in dem -devel Paket drin.
Hättest du das richtige installiert, dann würde die Kompilierung auch nicht mit "Could NOT find OpenMP" abbrechen.

lukas hat geschrieben:Wie löse ich das nun?
eventuell urpmi --downgrade?
Aber wie heißt das korrekte Paket, wie finde ich das heraus?

urpmi --downgrade libgomp kannst du versuchen.
Wenn du Pakete suchst, solltest du dir mal die Hilfe zu den urpm*-Tools durchlesen
Code: Alles auswählen
urpmf -f --name gomp

z.B. würde die alle Pakete mit gomp im Namen anzeigen aus den momentan eingerichteten Repos.

Siehe z.B. https://wiki.mageia.org/en/URPMI-de#urpmf

lukas hat geschrieben:woher weiß urpmi anhand devel(libgomp) welche version korrekt ist?


urpmi installiert automatisch die neueste, das macht jeder Paketmanager so. Oder was genau meinst du mit "korrekter Version"?
Ich bin nicht böse, sondern nur ehrlich. Und wer lesen kann, ist klar im Vorteil.
----
Mageia - the magic continues
Benutzeravatar
doktor5000
 
Beiträge: 5092
Registriert: Jun 2nd, '11, 09:39

Re: FreeCAD OpenCAMLib cmake error:Could NOT find OpenMP

Beitragvon lukas » Apr 11th, '19, 20:55

Danke für diese Erklärung, wieder etwas gelernt.
downgrade hat soweit funktioniert
Code: Alles auswählen
urpmi -downgrade libgomp-devel


make und install scheint soweit funktioniert zu haben.
Lib wurde auch in FreeCAD erkannt, 3D Pfade berechnen tut Sie aber noch nicht, sehr schade.

Glaube mit der urpmf Hilfe sind meine Fragen schon so halbwegs geklärt

Danke für deine Mühe.

lg Lukas
lukas
 
Beiträge: 25
Registriert: Mär 7th, '12, 14:21

Re: FreeCAD OpenCAMLib cmake error:Could NOT find OpenMP

Beitragvon doktor5000 » Apr 12th, '19, 10:43

Bitte noch Thread als [erledigt] markieren, dazu den ersten Post editieren und dem Betreff ein [erledigt] voranstellen, Danke.
Ich bin nicht böse, sondern nur ehrlich. Und wer lesen kann, ist klar im Vorteil.
----
Mageia - the magic continues
Benutzeravatar
doktor5000
 
Beiträge: 5092
Registriert: Jun 2nd, '11, 09:39


Zurück zu Erweiterter Support

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron